Updating firmware over wifi issue

I’ve had reasonable success updating the firmware over wifi with recent releases, but with the current release I get an error I haven’t seen before. In the past I’ve left it overnight and repeated and it usually goes through on the 2nd or third attempt, but not this time. It’s not easy for me to plug a USB connection in, but I could do that if needed. Brewblox itself is working just fine. I do have the API log requested, but I’m blowed if I can work out how to attach it to this topic. Anyway, let me know if that is needed as I’ve kept the file. The detail I see is:

Update failed: Request failed with status code 424
If retrying the update does not work, please run ‘brewblox-ctl flash’
Log messages
Started updating spark-one@ to version 423cbd6f (2020-06-23 12:32:58 +0200)
Sending update command to controller
Waiting for normal connection to close
Connecting to
Failed to update firmware: ConnectionResetError(Connected to wrong protocol (controlbox handshake received))
Scheduling service reboot

The log files are here:

Did you try again? I don’t know why yet, but it often works after the Spark has rebooted.

Well I had tried 2-3 times previously after turning the unit off and on, so I was going to reply that it hadn’t worked. But I turned it off and on again just now and hurrah the firmware upgrade worked just fine!

1 Like