Updating P1 core & script: Confusion [solved]

Recently received V3 and assorted thermal probes. (v0.5.1 factory installed) Nice looking product! Followed the Wiki Docker instructions and successfully installed HypriotOS & then BrewPi on a new RP3. I have the V3 controller plugged into the RP via USB. The RP is successfully connecting to my local LAN access point. (fixed dhcp reservation is the way to go) Can communicate with the BP web server via its IP address. The BP web server is talking to the V3 controller. The script is running. Can reach the RP command line via SSH and Portainer. I have a thermal probe installed and can see the temperature charted on my browser.

My issue is finding linear path to updating the V3 controller firmware. Let’s say I want to install v0.5.2.

  1. Update via Brewpi web server Maintenance Panel: Do I download the Core & P1 .bin files from GitHub to an accessible file location on my local PC first? Which .bin file should be selected first?
  2. Update via the RP command line access through the Brewpi Container console button, or from an SSH connection to the the RP. Then use python updater.py located in the /brewpi-tools directory. I must be stupid…I cannot find the /brewpi-tools directory anywhere. I have deleted the BrewPi container and installed the latest. Still can’t find /brewpi-tools. Think I’m missing something.
  3. DFU. I have yet to try this method yet. Still waiting for the mental lights to go on, I guess.

My beer is happily fermenting with my STC-1000, so there’s no deadline. Just want to get a good handle on applying updates. I suspect there will be a lot of them. Better I establish my chops now while there is no pressure. Dana

Anyone? How do YOU update the new Spark 3 (P1)? Via the Raspberry Pi command line, via the BrewPi Web interface, DFU, other? Dana

I haven’t updated mine yet but as I understand it if you installed with docker then you access it via the console like #2 in your previous post. Then you do this:

cd /home/brewpi/utils
python updateFirmware.py

1 Like

Many thanks, Gonzo. You provided the magic key. Somehow I did not see/register those directory & command instructions. Between the new wiki, GitHub, the brewpi forum, I probably just got a little lost.

The firmware upgrade to 0.5.2 went flawlessly. All is good. I will put a thermalwell in my fermenter and one in the freezer and shadow (data log) the current fermentation, which is 5 days old.

1 Like

Glad it worked out for you. When tuning your PID a few of us (with the help of Elco) have found the following changes helped to tweak it pretty good minimizing overshoot and getting it tracking the target temp:

Beer to Fridge Kp = 8
Maximum difference between fridge and beer set point = 10
Beer-to-Fridge Derivative filter delay time = 639 seconds (max)

They may or may not be the best for you depending on your setup but it can serve as a starting point to fine tune your PID.

1 Like

Excellent info. Thanks.

We currently brew 5 gallons of all-grain every two weeks in a 6.5 gal Better Bottle fermenter sitting in a 7 CuFt chest freezer. We wrap a fermwrap around the fermenter. The heat/cool is controlled by an STC-1000. The thermal sensor is taped to the outside of the fermenter with a chunk of styrene on top. No mishaps and lots of great beers for the past 8 years. We noted Elco’s warning about this method of heating.

We bought a 100 W ceramic infrared bulb and a 120 mm low-CFM fan for the heating in the freezer. Once the PIDs are dialed in, I expect our long-term hope for controllable fermentation profiles will become a reality soon.

One small glitch came up last night. I was unable to execute a Save As while creating a new profile from my iPad. The Profile name remained greyed out and could not be overwritten. I was attempting to load the sample profile, edit it, then save as. No luck so far. I’ll post this as a separate topic if that’s the right way to do it.