"waiting for datastore" until I restart service

I recently did a fresh install of Raspberry Pi OS on my pi and then installed brewblox.

I believe everything installed correctly but when I boot the pi and then go to the UI it just says “waiting for datastore”. If I run the commands “brewblox-ctl up” or “brewblox-ctl restart” the UI then loads correctly but the fix isn’t sustained after restarting the pi.

I should note that before I did all this, the UI loaded no problem without manually starting/restarting the services.

Any idea how to go about fixing this?



Could you please run brewblox-ctl log?

Yes I supposed I should’ve done that to begin with:

Not sure if it matters but this log was written while the “waiting for datastore” problem was still occurring on this particular pi boot:


The log command itself also threw this error:

INFO Log file: /home/pi/brewblox/brewblox.log
INFO Writing Brewblox .env values…
INFO Writing service logs…
INFO Writing docker-compose configuration…
INFO Writing Spark blocks…
HTTPSConnectionPool(host=‘localhost’, port=443): Max retries exceeded with url: /spark-one/blocks/all/read (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0xb5c44d50>: Failed to establish a new connection: [Errno 111] Connection refused’))
INFO Writing dmesg output…
INFO Uploading brewblox.log to termbin.com

This one was written after all the services were restarted and the UI was loaded:


There were no errors writing the log after the services were restarted.

If I understand correctly, the datastore issue is now gone?

Restarting the services fixes the issue but it comes back every time I restart the pi.

After restarting the Pi, what is the output of docker ps?

Your log contains warnings about undervoltage detected. Your pi is not getting enough power.

Right after boot:

After “brewblox-ctl up”:

Yeah I took it out of the enclosure and powered it from my computer USB to try to debug it, the problem existed before as well.

It looks like a flag is missing in the traefik service.

Edit: we had a few other changes, so decided to release a small update now. The fix to the traefik service is included here.
If you already updated your docker-compose.yml file, you can remove the restart: unless-stopped flag there.

just updated and is working perfectly, thanks a ton!