Weird temperature behaviour beer sensor

I am doing a testrun with my conical and I noticed something weird in the beer temperature sensor reading. When I change my setpoint from 22.5 to 23.5 the temperature reading from the beer changes with 1 degree also?!? When I change the setpoint back to 22.5 the temperature reading goes down with 1 degree agian…

brewblox-blocks-spark-two (1).json (7.5 KB)
brewblox-errors (2).json (35 Bytes)

graph-Conical Graph-spark-two-downsample_1m.csv (1.1 KB)

This is strange! Does this still happen if you unplug everything except the beer sensor? I’m thinking some kind of ground loop could affect the reading.

It looks like that when the heater pin state is high the temp reading changes.
The same counts for my glycol temp sensor. Thats also all over the place

It is de SSR that is switched on. I tried two SSR’s same result. They are both from aliexpress… :slight_smile:

What if the SSRs don’t switch any load? And does the supply voltage drop?

Which SSRs do you have?

Switching without load I tried with one of the SSR’s and it didn’t make a difference. Voltage drop is without SSR 4.71V and with SSR activated 4.68V. That seems fine I think.

I tried these two below:

Why is your minus not connected to the control board?

You also seem to have DC SSRs, what are you swichting?

The minus loose for the test without the SSR connected.

I am switching 12V DC. That’s what the heater element of Ssbrewtech eats.

For switching without the load, I meant disconnecting the load, not the SSR control signal.

Try keeping your high current load circuit completely separate from the control side.
Avoid that the return current for the heater goes through the same ground wire as the control side and the sensor side.
Each 12V wire going to the heater should have a GND wire right next to it.

12V supply plus --> SSR --> heater plus
12V supply minus <--------- heater minus

Think about which path the current takes and minimize loop area of the path. Especially avoid that the ground path runs through or past a different circuit. The current will follow the path of least resistance, you’ll want a ground wire going from the heater directly back to the power supply and right next to the 12V path.

The SSRs should have an optocoupler inside. So your paths for control and load can be completely separate and only optically coupled. No electric connection between them.

I did two tests:

  • load disconnected and SSR signal connected.
  • SSR signal disconnected

With the load disconnected and SSR signal connected the problem is still there. With the SSR signal disconnected the problem goes away.

The 12V power supply for the heater is completely isolated from the 5V for the spark. It is connected exactly as you describe.

I am doing a testrun now and it looks promising so far.
What I did is I connected the temperature sensors directly to the spark instead of on the SSR control boards.

Original setup with the fault present
Spark --> cable --> RJ12 housing connector --> cable --> SSR board 1 (with beer temp sensor) --> cable --> SSR board 2 (with glycol temp sensor)

Setup with tests yesterday also with the fault present
Spark --> cable --> SSR board 1 (with beer temp sensor) --> cable --> SSR board 2 (with glycol temp sensor)

Test setup now which looks promising, no weird readings so far… fingers crossed :slight_smile:
Spark (with both temp sensors) --> cable --> SSR board 1 --> cable --> SSR board 2

That’s great. To find the cause, can you measure of there is a voltage drop in the path? Check if GND paths have a voltage drop or if 5V is still 5V at the end of the path.

I just checked the voltage over the 5V and GND. I measured it at the bottom of the SSR control board on the soldering pads. The voltage is 4.73 with SSR off and 4.63 with SSR on. I checked all the RJ12 ports and the voltage is the same for all ports.

I have a new idea what the problem might be. I am no specialist in data communication but is it possible that due too short RJ12 cables reflection occurs and disturbs the data communication?

In my HERMS setup I still have the issue with the valves that does not respond sometimes. Here I have also a lot of short home made RJ12 cables…

From what cable did you make them?
My old brewing setup got a lot more reliable when I replaced the 6 wire phone cable with 8 wire CAT5e with only 6 of the 8 wires connected. Phone cables can be really thin and cat5 is much thicker. The cables I sell are made from CAT5.

It is also possible that making a cable a bit longer changes the resonance frequency and might actually improve things because the sensitivity to noise shifts in frequency.

I used the cable from your webshop. I bought a couple of long cables and used them for making shorter cables.

I think I’ll order a couple of cables in the webshop too eliminate the cables being the problem.

I received the new cables and did a testrun. Unfortunately the results are the same… The temperature readings are only stable when I plug the sensors directly in the spark. For now thats a solution…

So what more can cause this behaviour?

Only silence here… :frowning: I have a temporary solution for now but there is something wrong here and I would like to solve this issue.

Sorry, busy with too many things, have not forgotten about this. When would be a good time for a phone call?