Accessing the Web Interface

I had my brewpi working previously and then moved across the country. New router… new settings. I reconfigured the brewpi from scratch, but have not been successful accessing the web interface.

This is what I am using in /etc/network/interfaces file:




My router configuration looks like this:

Private LAN IP Address

Private LAN Subnet Mask

DHCP Start IP Address

DHCP End IP Address

When I run ip route show I get this:

pi@brewpi:~ $ ip route show

default via dev eth0 metric 202 dev eth0 proto kernel scope link src metric 202

and ifconfig produces this:

pi@brewpi:~ $ ifconfig

eth0 Link encap:Ethernet HWaddr b8:27:eb:6a:ee:f0

      inet addr:  Bcast:  Mask:

      inet6 addr: fe80::2c8e:570f:78bc:872c/64 Scope:Link

      inet6 addr: 2602:306:25a0:a1e9:d316:478c:339e:fa15/64 Scope:Global


lo Link encap:Local Loopback

      inet addr:  Mask:

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

When I go to the browser and enter, I get:

This webpage is not available


If I instead enter into the browser, I get:

Not Found

The requested URL / was not found on this server.

Apache/2.4.10 (Raspbian) Server at Port 80

Am I misreading the instructions? I thought .63 would be in the “safe zone” but it doesn’t seem to be recognized.

Thank you for the help,


Notice the DHCP start range .64 so .63 should never get handed out. Also it looks like you have your Pi hard wired since I see no wlan interface in your ifconfig (I usually tell people to use the -a flag with ifconfig just so you get a lot of detail).

I highly suggest unless you really understand how the networking works in a *NIX system you keep it simple. Setup the interface you wish to use as just plain old DHCP and then setup a MAC reservation in the router for that interface in the useable range. This will let the Pi always get the same address and save you some sanity. I even follow this in my setup and I have been a *NIX guy for many many moons.

Ok so now onto your web interface issue. From the error you got it just looks like you don’t have the content loaded, now this is probably due to the updates made in the Apache distro which points the default HTML dir to a different location. I don’t recall exactly where it points but there are post on this forum about it (also you can search the conf file for DocumentRoot and figure things out).

I hope this helps out.


I found it here:

That worked perfectly. Thank you very much!!