Brewblox - Wifi gets disabled (interface down) when docker network is brought up

The sequence of operations to reproduce are:

  • Fresh raspbian lite/desktop installation (from Pi Imager)
  • Apt update/upgrade
  • Follow the instructions to install brewblox
  • Everything works fine.
  • run brewblox-ctl up
  • Everything starts up correctly and it’s working fine
  • Reboot the raspberry
  • For a few seconds (I assume before the containers are started) everything works fine
  • The wifi network goes down and it’s impossible to connect to the raspberry (I have one connected to a monitor and everything works minus the network where the interface is down and it doesn’t come back up.

Next steps for me try with a wired connection but I would love to have the wifi working for obvious reasons.

This is an annoying issue with docker that is out of our control. It seems to be occurring when ipv6 is used. We added a command to disable it system wide:
brewblox-ctl disable-ipv6

Can you run that, reboot and tell us whether it made a difference?

I run the command and didn’t solve the issue.

Using a wired connection doesn’t have the problem and I can reboot at will.

I had this too, going into the Raspbian preferences and selecting wait for network at boot seemed to fix it.