Pi found on network but no ssh

Might be related with this or this.

seems to work fine but from time to time the website says:

This site can’t be reached

The web page at https://raspberrypi/ might be temporarily down or it may have moved permanently to a new web address.


I try to SSH and get

port 22: No route to host

But when I look into my wifi it says that the rasberry pi is connected to the expeced IP address (which is fixed).

This has happened a couple of times, I unplug the pi and plug it back in and it seems to recover.

If you go directly to the IP address, does that work?

You can also try https://raspberrypi.local to use mDNS resolution.

Actually now I have rebooted the machine and I still get the same result.

This site can’t be reached

raspberrypi.local ’s server IP address could not be found.


And when visiting the IP address? The host name is resolved differently than the IP address.

If the host name (raspberrypi) is flaky, then that’s a DNS issue. If the IP-based access is flaky, then it’s a network connectivity problem.

Tried with IP address. No success. the wifi network does see it and say that it is connected.

When you manage to connect, could you please run brewblox-ctl log?

It is not connecting now. I will see if unplugging it will be of any use.

If you use the app fing on your phone, does it show up?

I recommend not using a fixed IP on the pi, but instead creating a static DHCP lease on your router. That way you don’t have problems when you change routers and the fixed IP is not valid for the new router.

You can also use an HDMI cable and keyboard to validate on the pi that it has network.

OK so it seemed to have connected for a while. I was able to add an extra temperature probe (a total of 6!). But as I changing the graph to duration seems to have disconnected. I did not get around to do the brewblox-ctl log command.

I do not know what this is.

I am not sure what that is, I do not see it as an option on my BT router. It does say “Address assignment: DHCP”.

OK will explore that option. How do I validate from the command line? do I do a $ wget https://community.brewpi.com/ for example?

Most likely that’s it. If it asks for a MAC address, and lets you set an IP, then you have the right one.

Pretty much.

An app, for Android or iOS:

It can be used to scan the local network for devices see if your Spark and Pi are on the network and which IP address they have.

Strangely did not work the first 3 times. But then I found the pi in the network this morning.


I was now able to connect, and it was able to plot nicely. Does the log say anything that might have gone wrong?

  • We have had issues in the past with IPv6-enabled routers. You may want to run brewblox-ctl disable-ipv6
  • There’s an under-voltage warning that lasts for a few seconds in your log. How are you powering your Pi?

pi@raspberrypi:~/brewblox $ brewblox-ctl disable-ipv6
INFO Disabling IPv6…
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

I am using an amazon charger 5.25V and 1A is what is labelled. If it only lasts a few seconds it could have been when it fell off and was left hanging from the power cable.

For the Pi, a 5.1V / 2.5A power supply is recommended. Does not guarantee that caused your disconnects, but it’s a very common issue with similar symptoms.

1 Like

Thank you making an order now!

1 Like


I sometimes need to refresh the page a couple of times for it to show as connected. I changed around the power supply and added new thermocouple.

Is there anything else in the logs that I should be aware of?

Your log is showing some system-level crashes, but you’re also still using the couchdb-based datastore, which we replaced a while ago because it was causing errors. I’m not sure whether that’s responsible for these errors as well.

You’ll want to run brewblox-ctl update, and check whether the issue persists.

Something strange I noticed is that in your Spark pins block, the 5V voltage is read as 9.6V.

This should be impossible and if it was true, would damage things beyond repair.
You are only powering the board with USB right? Keep doing that, until we find the cause. With only USB power, no voltage would be able to go higher than 5V.

So it puzzles me.
If you connect nothing to the spark, do you still get this strange high reading?
You say you added a thermocouple, I assume you mean a OneWire sensor?

Do you mean disconnect the onewire sensors? I have 6 will need to label them to make sure they go to the same place.