Cannot receive LCD text from Python script

The error above is something that comes on when viewing the web interface for 5 seconds and then changes to my temps along with “Script Running” for 5 seconds and then back and forth it goes in a loop.

I have a Raspberry 3 and the Spark connected via USB with the Raspberry plug into an outlet. I did need to start with an image of Raspberry instead of NOOBs due to not being able to get my cardreader working right with NOOBs. I have updated the Raspberry PI to latest versions, updated BrewPi to latest version (I think .42 or .43 whichever is in the master). I am using wifi on the Pi to connect to my network. I have tried disabling the wifi checker and it did not work. I have also tried rerunning the permission commands in the setup guide (for version .30) and it still errors out then begins again.

One note for the Spark, I did try to connect the Photon to my router through a particle app on my iPhone by putting it in setup mode and connecting through the iPhone app. It never finished connecting and that’s when I assumed it wasn’t enabled yet. I was originally going to connect it to my Windows computer through WIFI but gave up. Then I went the Raspberry Pi route.

Any help in troubleshooting would be great. I have read from searching for this error but either it looked like they couldn’t get the script to run at all or the solution didn’t seem to work. (or I am enough of an idiot to not understand - which is likely.) Lastly, I am pretty new to the Pi, Linux and BrewPi.

it’s something to do with a refresh rate in the safari web browser, everything will still be working fine, and it’s pretty easy to fix see the link below, this problem has come up so often. Alternatively to can just use chrome for iOS and it works fine.

Thanks mikmonken!

I saw something about this mentioned in the install but thought it was just related to Safari. I was using Chrome on my phone and Internet Explorer on my Windows box. Changing the value to “99” seemed to work. Here were my steps for documentation purposes:

  • Putty into Pi or however you access it.
  • Use “> sudo nano /etc/apache2/apache2.conf” to open superuser rights to edit file.
  • Scroll down to “KeepAliveTimeout 5” and change value to “99”.
  • Save and exit editing Apache2 (Ctr X and answer the ?'s)
  • Restarted Apache2 service: “> sudo service restart apache” - This didn’t work for me. It said service not found. So I rebooted the Pi: "> sudo Reboot."
    Looks like it worked when it came back for all my browsers.

Again - appreciate the help!!