Connect ispindel

How do I connect an ispindel to Brewblox?

The iSpindel can publish data to MQTT. Send data to the Pi address at port 1883. Publishing history data | Brewblox describes how to format the JSON payload.

1 Like

I’ll try and see if I understand how to do it during the weekend :slightly_smiling_face:

I think brewblox support is built in and doesn’t require something custom. You should be able to select brewblox in your ispindel config.

1 Like

Anything else I need to do? I entered my wifi credentials, set server address but it doesn’t show up in Brewblox.

You can use to check whether the message is being received by the brewblox eventbus. Connect to the same address as you’re using for the iSpindel.

1 Like

seems like mqtt-explorer receives stuff from brewblox, but how do I check if brewblox receives anything from mqtt-explorer?

If you use mqtt-explorer to send a message, and you see the message show up, the brewblox eventbus has received it.

Tried to send something but nothing showed up. Never used it before so I might do something wrong… But to see if it worked, I connected the ispindel to brewfather and it popped up right away. So I know it works :slight_smile:

Tried with another brewblox installation I have but doesn’t show anything there either…

Looking at it: by default the brewblox eventbus is passwordless. Does it work if you remove the username and password?

No. Should it pop up as a service?

No, there is no iSpindel service in the UI. The fields should appear for selection in Metrics / Graph widgets.

1 Like

Doesn’t show up in metrics. only spark one

Ok, to recap:

  • What are your settings for iSpindel?
  • What are your settings for mqtt-explorer?
  • Do you see iSpindel messages show up with mqtt-explorer?

And the basics: are they in the same LAN and is the the IP you entered the IP address of the pi? (not the spark!)

They are on the same LAN and I set the server IP on the ispindel to which is the IP of my Brewblox server. I also tried with another pi with brewblox that has IP Nothing shows up. Maybe I misunderstood how to use mqtt explorer, I put in the IP adress to my Brewblox server so only got some reply from that. I found the Ispindel ip address and tried to put that in mqtt explorer but it wouldn’t connect to it. But it works great in brewfather. It shows up as a device and updates every 15 minutes.

To clarify: The iSpindel → Brewblox communication is done using the MQTT protocol.

MQTT is a protocol where messages are published to a central server (our eventbus). Each message has a topic and content.
Everyone listening to a topic is notified when a new message with that topic is published.

The iSpindel publishes messages to the Brewblox eventbus, using a pre-defined topic (brewcast/history).

If you connect MQTT Explorer to our eventbus, it is subscribed to all topics. You can use this to listen in to all published messages - including those from iSpindel.

Both iSpindel and MQTT Explorer need to be connected to our eventbus.
The eventbus runs on the Spark server, and uses port 1883. There is no username and password.

For you, this means both MQTT explorer and the iSpindel need to connect to at port 1883.
If you connect MQTT Explorer, and see messages from the Spark show up, but not those from the iSpindel, it means that the iSpindel is either not publishing, or is attempting to connect to the wrong address, or with the wrong credentials.

Again: in your earlier screenshot, you had username and password set in the iSpindel connection settings. I suspect that is what caused the problem.

1 Like

Thanks :slight_smile:
I changed service type in ispindel configuration from Brewblox to mqtt and now it shows up in mqtt-explorer. Now I just need to get it to show in Brewblox :slight_smile: Any tips on how I can do that?

The “brewblox” output type of iSpindel also publishes to MQTT, but with the brewblox history data format.
This does mean your connection settings are good. If you switch back to the brewblox service type, it should still publish, but now under brewcast/history/.

1 Like