Edge release 2019/07/18

Firmware release date: 2019/07/17

Due to Elco’s upcoming holiday, we decided to push some firmware changes now. This leaves us time to fix any critical issues while he’s still here.

This release does include a pretty exciting change: we can now update firmware over Wifi! You can even run it from the UI, without having to restart your services.

IMPORTANT: If you skipped the last update, you’ll need to run brewblox-ctl flash to enable updates in the UI.

The new mechanism is experimental, and may require a retry before it works. There are multiple checks in place to ensure that if an update fails halfway, the current firmware is not corrupted.


  • When the PWM setting is less than 5%, its actuator will not be listed as waiting for the Mutex.
    • This is mostly a cosmetic change, to prevent actuators visibly waiting for the Mutex because the PWM setting (briefly) jumped to 0.0001.
  • Fixed a bug where errors in the OneWire bus would cause the Spark to be stuck after rebooting.
  • Enabled flashing the firmware in the UI. It can be accessed from the actions button in the Spark service page.
    • This is available for both USB and Wifi connections, and does not require other controllers to be unplugged.
    • brewblox-ctl flash is still available.
    • If you’re updating from an older version, you’ll have to run brewblox-ctl flash to enable this feature.
    • The UI will prompt you to update if an older firmware version is found.
    • brewblox-ctl update no longer prompts you to flash the controller.
  • Brewery Builder changes:
    • Removed the % sign from the Pid Display part
    • Added the Url Display part. You can use this to easily navigate to local or external links.
    • The fridge wizard adds an Url Display that links to the fermentation arrangement guide.
    • PWM Display / Heating element parts are now clickable, and open the PWM settings dialog.
    • Pid / PWM displays now show achieved output values.
    • When closing / reopening the Builder editor with the Delete tool selected, the previous tool will be used instead.
    • Added a search field to the part catalog (shown when adding a new part).
  • Unit edit dialogs now use a value rounded to 2 decimals.
  • Reworked how constraints are displayed.
    • Normally, only the currently limiting constraints are shown.
    • Clicking the field opens an edit dialog.
    • This standardizes how constraints are rendered in widgets and block setting dialogs, and removes the need for an expansion item in setting dialogs.
  • Removed expansion items (collapsable subsections) from block settings dialogs.
    • During the last few months, we’ve moved generic actions and less relevant fields to dialogs and actions. This made the expansion items unnecessary.
  • Fixed an issue where API errors would generate useless error messages about commits only being possible in dynamic modules.

Relevant links:

All good so far for me, with one exception one of my three fridges lost the link to channel B on its DS2413 chip, it was blank?
Was previously linked to the cool actuator. Reconnected no problem.

That’s kind of weird. We’ll keep an eye out for the problem reoccurring.

I tried to do a clean install and and i got stuck here:

Which Raspian version?

Docker screwed up their dist version for raspbian.

You can try running export CHANNEL=InRelease; curl -sL get.docker.com | sh to force an available dist.

Add yourself to the docker group afterwards (script prints the command, and then reboot your Pi)

I downloaded Raspbian Buster

Yeah that’s not supported by docker. Use previous version instead.

I also encountered the problem with loosing the link on channel A on two of my DS2413 chips. This has happened several times.

I’ll make an issue for it. Anything specific that seemed to trigger it?

No, i can´t see any pattern when it´s happening. Just random.

Hi, I have just done the upgrade and now none of my actuated valves open/close.Brewblox says opening but nothing happens? Any pointers?

Are you trying to open them one at a time, or in combination (through the step view).

Some troubleshooting steps you can try:

  • check the status LEDs on the expansion board while opening.
  • unassign / reassign the channel in the motor valve blocks
  • power cycle the controller
  • unplug your valves, and reconnect 1 by 1 while retrying. A single faulty one can have knock-on effects.

Also check that you have not swapped the open/closed feedback pinsand that the boards get 12V.

Removed all blocks and recreated, but still the same no response

Had an unsolicited popup this evening inviting me to update my firmware …


The actions menu says I’m on the latest …

Just for info

You got the whole dialog as automatic popup, or just the notification w/ button?
At which point was this? During update / normal use / something else?

Behavior when firmware updates are available is still experimental. We want it to be noticeable without being overly annoying.

Note that it only checks the firmware binaries carried by the Spark service. It’s not a reminder to run brewblox-ctl update, but that you’ve run the update, and haven’t flashed the controller yet.

What do the extension boards status LEDs show?
Did you check what Elco suggested?

Could you please post your logs ( brewblox-ctl log and then copy the termbin url), and your blocks (spark service page, actions, import/export blocks)?

It was initially a popup as I opened the browser, I then clicked on it and it gave the notification above.