Edge release 2019/07/18

Hi Bob, I will send this evening - although now I have only one block with one valve, as i deleted everything else. As for pins I did not do anything, so not sure how I could have swapped feedback pins.

1 Like

@Trig @cweger found the issue with the DS2413 links. Fix will be in the next release.

@joyosa A related problem was caused by 12V being disabled in the Spark pins widget. You may also want to check there. 12V on the RJ12 connectors was enabled by default, but this changed in a recent release. Most people don’t need it so it is safer to not enable it by default.
We’ll add a warning to the motor valve widget in case it is disabled.

Many thanks, so on the valve widget, there is an option to enable 12v?

You can find the actual setting in the Spark Pins widget settings. Next release will include a button on the motor valve widget.

To enable it now:

  • go to the spark service page.
  • click on “SparkPins” to show the widget.
  • click on the settings button.
  • toggle 12V on.

brewblox.log (82.7 KB)
I enabled the 12v and the valves worked, however after the latest patch - the same problem.
I removed all the blocks and then created a new block and assigned the valves. I see valve opening message but nothing is happening.

Could you please export your blocks? (Spark service page, under actions)

If you go to the Spark Pins widget in your service page, and click the settings button, what voltage does it show under 12V?

OK I will do that once I return home

brewblox-blocks-spark-one (2).json (2.6 KB)
Attached is the block that is setup

Thanks! And the voltage?

12.11v is shown in the settings

Configuration seems correct.

  • It says current state is closed. This is correct?
  • Which LEDs are active on the DS2408 expansion board if you try to open a valve?
  • If you try to open a valve, does the status stay on “opening”?

The board has 2 green lights active and a red light. One valve is open, the other closed. This is how they were before the upgrade and when toggling them on/off in brewblox, nothing happens. I have also rebooted the pi.

The issue seems likely to be a firmware problem. You mentioned it worked when on the 07/23 release.

I just released a test version of that firmware version, so you can check.

To install:

  • Open your docker-compose.yml file on the Pi, in the brewblox directory: nano docker-compose.yml
  • Scroll down until you see the spark-one service.
  • The first line says image: brewblox/brewblox-devcon-spark:rpi-${BREWBLOX_RELEASE:-stable}
  • Replace everything after the : with rpi-test-firmware-rollback
  • It should now be image: brewblox/brewblox-devcon-spark:rpi-test-firmware-rollback
  • Press ctrl-X to exit the file.
  • Type y and then ENTER to confirm saving the file.
  • Run brewblox-ctl update.
  • Run the firmware update in the UI to update the firmware.

brewblox.log (3.2 KB)
The update did not work, here is the log file

You applied the change to the wrong service.

Replace your docker-compose file with this file, and then run brewblox-ctl update

docker-compose.yml (2.6 KB)

brewblox.log (81.3 KB) It is still erroring out

brewblox.log (85.8 KB)
It is still erroring out

It looks like it’s still using the 07/25 firmware. You can update this in the Spark service page, under actions.

It should show firmware release date 2019/07/23

I can not log onto the web page, as brewblox-ctl up errored out