How to use the brewery builder

Dear all,
I can’t get the brewery builder to work on my dashboard or at least I have no clue how to do that.
When I add the widget to my dashboard, it shows an empty panel which I think is ok so far
By clicking on the Editor button, I get an empty layout panel with a menu at the side.

How should I proceed from there? There are no elements visible I could place on the layout so the actions offered in the menu are useless.

Any hints or ideas?

Kind regards

With the “New” tool selected, click anywhere in the grid. You’ll get a popup with the part catalog.

That simple, really? I would have sworn I tried that before but obviously not…
Thanks for your help!

1 Like

If you want a standard setup for fermentation, there is an option for that in the Wizard!

Nope, I’m driving a HERMS system. :slight_smile:

Wow, nice! Enjoy setting it up!

Hi, to get some inspiration:



Thanks. I still use hose swapping instead of fixed tubes with automated valves. But your setup sure looks nice and something to aim for. :slight_smile:

What’s the size of your system?


Hi Wolfgang,

The picture was meant as an example of a HERM setup, (eg mine :expressionless:).

It’s still with hoses (no swapping) and manually operated valves. I’ve 15-gallon pots.


We did our first brew with the new setup - a Pale Ale batch with 45 gallons. Everything went fine, the heating rate could have been higher (only approx 0,5°C per minute while mashing) but that’s something I’d expected. Brewblox software and BrewPi’s hardward did a tremendous job!


My “Editor” button is dead
Nothing happens when i hit it
any Ideas?

If you create a new builder widget, and use the editor from there, does that work?

If you open the developer tab (ctrl+shift+i) before clicking the button, does that log errors?

Guess it does (im not a dev)

[object Error]: {description: “,0 could not be parsed as a coordinate”, message: “,0 could not be parsed as a coordinate”, stack: “Error: ,0 could not be parsed as a coordinate at Coordinates ( at overlaps.get ( at get ( at evaluate ( at computedGetter ( at Te ( at t.prototype._render ( at r ( at get ( at run (”}

Looks like it managed to corrupt the layout. Could you please enter the following URL in your browser, and save the results to file?


Replace PI_ADDRESS with the actual IP address of your Pi.

Here you go
brewblox_datastore.txt (10.6 KB)

The problem seems to be caused by a builder layout only containing a handful of kettles, all with invalid X/Y positions.

Do you know when and how the kettles were created? Did you do it, or did a bug add them?

The simplest solution for now is to remove the offending layout. I’ll make an issue to validate and handle corrupted layouts in the UI.

On your Pi, run the following command in your brewblox directory to remove the layout:

brewblox-ctl http delete https://localhost/datastore/brewblox-ui-store/layouts__2386ff68-109f-b64f-5639-d08b42cdb259?rev=8-3ef092ff9fe8b8c676a69506857b871e

I probably created the kettles when i was playing arond

OK, that worked for a while
Deleting the old kettles worked find and for a few moments the Editor worked
As soon as i added the kettle, it broke again

Am i doing something wrong?

I think I found the problem. It seems to be a variant of an annoying bug we fixed a while ago.

Are you opening the editor while the page is scrolled? When finding the grid square you clicked, it incorrectly takes the page scroll offset into account. Placing the widget at the top of the page, and opening the editor without scrolling the page should be a workaround until we release a fix on tuesday.

To make your editor accessible, feel free to post the datastore again, and I’ll dig up the one that should be removed.

1 Like

Yes that is probably the case, page was most likely scrolled
brewblox_datastore_part2.txt (1.4 KB)