Just started a fresh batch

Not used to seeing the beer temp go up almost 3 degrees for the setpoint of 68 degs.
Just started this batch yesterday and the temp control was ± .5 deg. Looked just now and I’m getting a little nervous… Fermentation just started going full bore so maybe just needs to catch up ??? Any thoughts ???

Could you please add screenshots of the cool/heat PID graphs? You can access those from the service page.

That swing looks very much to me like the heater and compressor competing. The double drop looks as you would expect if the compressor kicks in twice. I expect you just need to increase the dead time in your mutex. If you can reduce the swing, I’d expect the PIDs to be much happier.

I put it in Beer Constant Mode and then back using the profile and it looks as if it is controlling as I’m used to.

I did notice that the temperature probes were “stuck” at values that were not correct on the Spark. Didn’t change when I held on the them. The dashboard on the Pi Server the values changed. I rebooted the Spark and the values started showing the correct values. Not sure what that was about.

The heater has not been active so far for this batch.

Not sure what went on but it seems to be controlling as it has in the past…

Something seems wrong with your settings.

Please show:

  • Your block relations diagram (spark page, button on the top right)
  • Your PID settings

Found the active PID’d…

You have two active fermentation chains. You can see the relations diagram being mirrored, with eg. Ferment Heat PID on the left, and Ferment Heat PID-2 on the right.

If you haven’t customized your settings much, the simplest solution may be to remove all blocks / dashboards, and re-run the quickstart wizard.

See https://brewblox.netlify.com/user/removing_things.html for more details.

I see what you are saying. I have made no changes since upgrading to BrewBlox.

It is controlling right now so I’ll let it finish and do as you suggest.

Any thoughts on how this could happen ?? Probably operator (me) error !!

Maybe changed your mind on linked sensors / actuator ports, removed the dashboard, and ran the wizard again.

We automatically pick names that aren’t in use, so this easily happens without any kind of errors. Technically speaking, it’ll work just fine: the last run wizard will claim the actuator ports.

While this is technically desired behaviour (it’s very easy to generate a fermentation config, and the wizard adapts well to existing blocks in the system), we’ll have a look at making it more visible for users.

So I can select the last item “Remove all Blocks” and then rerun the quick start wizard ??

Yes. Do also remove the dashboard before running the wizard again.

Edit: it also helps to keep note of which sensors / actuator ports you are using. Either physically check, or write them down.

I’ll give it a try next week. Have a batch fermenting and so far it has been controlling.
Thanks for all the help !!! To be continued !!!

Is this what I need to keep track of ???

That, and the actuator pins (top/bottom 1/2/3).
Another approach when recreating is to plug in and name sensors one by one.

Okay, last batch is done fermenting. I am going to do as suggested and remove all the blocks and dashboards. I currently have two. The one I setup and on called Home Dashboard. Is Home Dashboard a generic kind of default ??? Should I delete it too ??

There’s nothing special about home dashboard. It’s generated during setup to not have an empty list of dashboards.

Should I delete it before I remove all blocks ??

The order doesn’t really matter.

That went well !!! Thinking this looks the way it should !!