Loading the portainer web interface


#1

I am trying to set up a brewpi to work with my Raspberry 3. I got to loading the Portainer web interface. I can’t find the interface. Can you elaborate on where to find the interface? Do I type the IP address into the Hypriot command line?

Thanks for your help, I better with the hardware part then the coding part


#2

You should go to http://[ip address of your pi]:9000 from a PC.


#3

Hi Elco
I had an issue with the SD card used for BrewPi running on Raspberry PI 3 and need to reinstall the system. I tried to use the portainer, but cannot deploy the portainer since the statement below cannot be executed. What should replace --name in the
Statement:
–name portainer portainer/portainer -H unix:///var/run/docker.sock

Shouldn’t the portainer be created with a name like the following
$ docker volume create portainer_data

Cheers Ken


#4

That is an incomplete statement. Did you copy the entire line? It should be:

docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock --restart always --name portainer portainer/portainer -H unix:///var/run/docker.sock

#5

Hi Elco
Thanks for your reply. I was not aware of that the entire statement must be executed as one string. I have successfully created the containers as shown below, even the published ports look’s a bit different than as shown in wiki.brewpi.com. Does it look correct?


I got the error below when trying to connect to BrewPi Spark over wifi.
What should IP address be set into BrewPi spark? Is it 172.17.0.3?
image

Cheers Ken


#6

that looks correct. I have not taken a new screenshot when I added port 81 for the password protected interface.
The IP address of the Spark is displayed on the LCD. The IP address above is the IP address on the docker network. You can ignore it.


#7

Hi Elco
I have the previous version of BrewPi Spark which does not have wifi, so I guess that I have to communicate through USB?

Cheers Ken


#8

Your BrewPi Spark V2 does have WiFi. Use the Particle app to set it up.


#9

Hi Elco
Currently I have newer used Wifi connection from my Spark v2. I need to update firmware from version 0.4.4 to most recent version like


But currently loading the files from Github makes troubles. There might be an easy way to do this.
BR Ken


#10

Yes, you should run this command twice:

docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-raspbian python utils/flashDfu.py --tag=0.5.4 --noreset --autodfu

Exit with CTRL-C the first time. It should now be running in DFU mode. Then run it again. When you have set up wifi, the Spark will download a new bootloader from the Particle server.


#11

Hi Elco,
I tried to run the entire script and got the message:
“dfu-util: Cannot open DFU device 2b04:d006” I am sure you know why.
The 2nd time the script was executed the final screen message was

Download done
File downloaded successfully
Programming done

The new firmware version 0.5.4 is successfully installed

Use of the Particle app went also successfully, giving the BrewPI Spark an IP address 192.168.1.172 on the screen.

I have changed the IP-address in the maintenance panel (http://raspberrypi.local/#), but I cannot update the device list. I got the following error:

Error while receiving device configuration: Couldn’t write to socket: [111] Connection refused Is the script running?

The script is not running and I cannot get it running for some reasons?
I can Ping the device over my network, so far so good!

Thanks for your help!

BR Ken


#12

In the maintenance panel -> log files, you should see the error that causes the script not to run.


#13

Hi Elco,
There is nothing logged since 22mar2018 as shown below, which is all that’s found under Maintenance/View Logs tab. Looking in our community I can see others have had the same issue, but obviously, no one after you introduced the Docker technology. Can it be something with the folder structure on my Raspberry Pi? When I press the key “Start Script” nothing is logged in the “log window dialog”. Does this say something? Maybe that the system is not running at all. Everything looks fine on Brewpi Spark showing IP address 192.168.1.172.

Hope this gives you a hint!
BR Ken

Mar 22 2018 20:43:54 Notification: Script started for beer ‘My First BrewPi Run’
Mar 22 2018 20:43:54 Connecting to controller…
Mar 22 2018 20:43:54 Background thread for serial started
Mar 22 2018 20:44:04 Warning: Cannot receive version number from controller. Check your port setting in the Maintenance Panel or in settings/config.cfg.
Mar 22 2018 20:55:05 stopScript message received on socket. Stopping script and writing dontrunfile to prevent automatic restart
Mar 22 2018 20:55:05 Background thread for serial stopped


#14

Hej Elco,
I have just tried the USB connection (serial port), but I cannot start script either through that interface. There is nothing communicated to the log windows (stderr:), which is really strange, since I stil got the error shown below, when trying to refresh devicelist?

Error while receiving device configuration: Couldn’t write to socket: [111] Connection refused Is the script running?

BR Ken


#15

Hi Ken,

This was caused by a bug that I just fixed.
If you update the container (in portainer click the recreate container button and pull the latest image), then it will start working again.

Sorry for the trouble it caused you.


#16

Hi Elco,
Sounds good you found a bug and fixed it :slight_smile: :+1::+1::+1:
I am not sure how to recreate containers and pull the image, is it with this script “docker-compose up --build”?
BR Ken


#17

Hi Elco
I found the recreate button, but running the recreation gives a failure “Unable to remove container”, then the contianer list is empty.Shall I reload the containers by running the portainer docker image?
BR Ken


#18

Ah, I think you tried re-create portainer. This doesn’t work, it cannot recreate itself.

Remove the old container:

docker stop portainer
docker rm portainer

And then create it again with the docker run command as described on the wiki.


#19

Hi Elco,
I have created the portainer again with the docker script, but the script will still not start. Do you think I still have the version with the bug?.
If I restart http://raspberrypi.local/ the web interface does not remember the IP address. Does this give you a hint?
BR Ken


#20

When you did ‘docker run’, it re-used the old image. You can now just recreate the brewpi container and pull the latest image from the portainer UI.

The IP address is received and stored by the script, so without the script running it will indeed not be remembered.