Mock Temp Sensors Misbehavior

Edge release 2020/04/06

Fahreinheit temps on the Spark display got fixed. :star_struck:
But now the mock temp sensors are hosed.
When I type a temperature, it multiplies that value I enter by 9/5 and adds 32.
In other words, I have to enter temps in Celsius to get the temp I want.

Also, and a much worse condition…

I cannot change any setting of any block, other than the mock temp sensors.
I get the following error message:

Failed to persist . Request failed with status code 500

Updating again and flashing from the command line resulted in no change.
Adding new blocks and deleting them works.
Changing any setting (even turning an actuator on/off gets the same error.

Setting values is now fixed and live. The change only includes the UI, so you can get the update by running

docker-compose pull ui
docker-compose up -d

It appears that right now the Docker image host is having some issues. If you see TLS handshake errors while pulling, you can retry the pull.

This may also fix the 500 response error, but I can’t say for sure. If it doesn’t, could you please

  • open your developer tab in the browser (ctrl + shift + i)
  • go to the network tab
  • trigger an error (it should appear in the network tab as red entry)
  • save the network tab as HAR. (right click on the network tab, choose “save as HAR”).
  • upload the HAR file. It contains network requests for the associated tab.

I was having the same issue (500 response error) and your update seems to have fixed it.

1 Like

running those commands ran fine with no errors.
but ended up getting me here:

and the Spark in a boot loop. unplugging USB (sole power and comm source) and reconnecting doesn’t solve the Spark condition.

The Spark boots, progress bar goes all the way to end, it says “Ready” then led turns red with a series of flashes that is too complex for me to count this early, followed by 7 slow flashes.
Does that light show twice, then reboots.

Flashed the Spark using this procedure:

I noticed this in the feedback:

INFO Flashing Spark…
Triggering dfu on port /dev/ttyACM0
[Error: Error: No such file or directory, cannot open /dev/ttyACM0]
Flashing P1…
Flashing System 1 file…
Flash success!
Flashing System 2 file…
Flash success!
Flashing Firmware file…
Flash success!

This brought the Spark back online.
When I opened up the interface, I got a notice stating there firmware update available; snoozed that.

Setting values is good to go now.
500 response errors are gone as well!

Impressive support! :star_struck: