Monitor Problem

I have a problem with the brewpi monitor:
When the system is started, the monitor runs perfectly, after a few minutes only a white screen is visible. Furthermore, the system “resets” sometimes and the pi + brewpi restart.
What can i do?
Thx.,
br
Tom

It sounds like you’re using an underpowered USB charger for the Pi.
If this is about Brewblox, could you please run brewblox-ctl log?

It works allready a few time - at 1 Week i have this problem…

Yes, that is possible. If your charger is underpowered, you Pi will reset when it draws too much, but may work the rest of the time.

Without log output, or a photo of the charger’s technical specs, I don’ know for sure.

Ok - see attached Photo,
br
Tom

The charger is fine, so let’s move on to the next item.
Which software are you using? BrewPi or Brewblox? If you’re not sure, feel free to make a screenshot/photo of the UI.

If you’re using Brewblox, could you please run brewblox-ctl log?

Im using Brewblox.
I have run the log - attach. the log file.

complement: i’m using 2 Brewpi with my PI 4.
After Start the PI both brewpi works well, after a few minutes one of the two brewpis (always the same) only shows a white screen (as seen in the photo)

Down you will find the log-file.

0n5l.txt (340.2 KB)

When you get the chance, you may want to update. You’re currently using the 2020/08/31 release.

More immediate, I think the problem is caused by connection settings for the spark-one service. You have two sparks:

  • spark-one: 3c0037001851353530333533
  • spark-two: 1d0039001147383531363134

In your compose file, spark-two has a --device-id argument, but spark-one doesn’t. It will randomly connect to either of your two sparks.

To fix this, run brewblox-ctl add-spark -f -n spark-one, and select the discovered spark with ID 3c0037001851353530333533.

This fix can be applied without interrupting your fermentation, as it will not change anything on the controllers themselves.

… i have 3 devices…?

Do you have three devices? Those are unique serial numbers.

I have 1 Pi with 2 Brewpis (so i wrote) and 1 Pi with 1 Brewpi (at this time both pi’s are running)

Ah, that explains it then.

When you run add-spark, choose the 3c0037001851353530333533 option, and it should work out.

On your other Pi, check whether that’s set to use a device ID. If the two Sparks connected to this Pi are (or become) wifi-enabled, your second Pi may connect to it.

I have try this, the brewpi runs well, but after a short time (approx. 15min) the white screen comes again…

The white screen is unlikely to be a software problem.
The display cable might not be inserted into the connector properly.

Can you open the unit and check?
You can also make a high res photo of both sides of the board if you want me to check for issues.

hmmm… i will check it when the prozes is finished (Eventually at the Evening). But i don’t believe that this is the olution for the problem because the screen woks normallyf or a while after a restart…
I will try it.

So, i’ve open the Brewpi - see Photo att. Then i opend the cable-holder, press the cable into the holder and closed it. Now the screen works well. I think that was the provlem, bur i remeber i had the same one approx. 3/4 Year ago… I hope that will be the last time because its only on this Brewpi, my orher two BP works well all the time…

Great! Hope that fixed it and the problem was indeed that simple. If it still acts up, send me a message for a replacement.