Monitor problems

I seem to have some monitor problems, I will try to explain them.

  1. On the RPi the chrome is not responding as it used to when I enter the IP address. I see waiting for reply. It also has problems with handling TeamViewer, problems I have not had before. Is there a full buffer somewhere?

  2. On both PC and Rpi I cannot set the graphs time scales to more than the last 8 hours.

Looking forward

It could be that something is using more memory after an update. We had to tweak a docker command because it suddenly was causing the Pi to run out of memory.

How/why are you using teamviewer for your Pi? That seems inefficient.

Can you not set the graphs to further back, or are you simply not getting data? What happens if you select a 1000d period?

Perhaps I should look for a new update, it’s been a while.

I use teamviewer when I am at another site, but I have a workaround here.

30d worked. On the pic here I have set for 3d.

Keeping the software updated is always advisable. The next release will likely happen on monday.

If there’s a gap in you data, there may have been connection problems with your Spark. Could you please run brewblox-ctl log?

Maybe route teamviewer to your home computer, and access the UI from there? We’re using the Pi as cheapest way to get a server. There isn’t that much RAM to go around.

Yepp, as you see I have a brew running. Can I run the log command now
without interrupting the brew?

brewblox-ctl log will not interrupt your brew. I would wait with updating until it’s done though.

I ran brewblox-ctl log

Also, when I update will the latest cover all, or do I have to go back and do them one by one?

What is the result link from log?

The update command immediately downloads and installs the latest version of the software.

Thanks! In the future it’s also fine if you just post the url (

Two things stand out:

I’m seeing some network interrupts and service reboots that are usually caused by IPv6 issues. Running brewblox-ctl disable-ipv6 usually fixes this.

Your Pi is showing multiple errors about a bad USB device / connection. It seems to be the port used by the Logitech keyboard and mouse that showed up in logs before that, but I’m not 100% sure.

Hmmm, how can these errors be the cause of the display problem?

The display shows a sliding window of the last 8 hours, Not back to a point where an error occurred. This observation is the same for all displays, at least several ones that I have checked.

If nothing comes up, I will continue the fermentation and then see what blessings an update will bring along.


A sliding graph range sounds like an issue we fixed a while ago. The fix predates the version you’re currently using, but it’s possible that the history database config check during the update will solve the problem. As you said: we’ll see what happens after the update is applied.

The errors from your log are indeed unrelated, but were still worth mentioning. IPv6 tends to be an issue when it’s acting up. I’m not sure whether the USB errors are serious, or just noise.

I have disconnected the USB to the Logitech devices.

Can I run the brewblox-ctl disable-ipv6 command without disturbing the fermentation process?

Yes. The Pi is not involved in direct temperature control - your Spark is.
The Pi is used to change settings on the Spark, and collect history data.

Make sure the Spark is connected to a power supply, and you can tinker with the Pi without disturbing actual control.

I am running my fermentation process and it seems that BrewBlox is doing its job well.
However, there seems som be some noise here. I’m sending you some screenshots and ask your advice as to how I should go about this when my fermentation is done.

The temperature range between min/max is ~0.05*C. At that point, you’re mostly seeing random bit flips in measurements. The graphs look choppy, but in absolute terms, temperature control is dead on.

From your last graph, there does not appear to be any rubber banding either. Your system keeps turning on the heater, but never the cooler.

At a guess, you’re using a Setpoint Driver to control fridge temperature? You could switch to direct beer control to simplify the control chain, but that’s mostly preference if the current setup works just fine.

Thank you. I see there are som low-pass filters at some stages. I was wondering whether they could do with some adjustments.

The graph shows unfiltered data. If you want to see the filtered version, you could select the PID inputValue field in the graph. I believe (but am not 100% sure) that shows the measured value after filteres are applied.

The setpoint block has a filtered and unfiltered temp. I would select it from the setpoint. That’s also where you configure the amount of filtering.

Thank you. Would you like to suggest a filter setting?