Raspberry died while doing update

This happens because you flashed a new image. Your own computer sees that the fingerprint for your Pi changed, and freaks out.

To fix this, remove the stored fingerprint by running this command on your windows pc:

ssh-keygen -R {PI_ADDRESS}


The host should be the name you use to ssh. Going from the earlier error, I think that’s either raspberrypi or raspberrypi.local (or both)

When I flash for the Spark, I get the message
Only if the LED is blinking blue after the firmware is flashed , run:

I usually see the blue light breathing and not blinking. Do you literally mean blinking but not breathing?

Yes. Blinking and breathing are two different things. When it’s blinking, the screen will also be completely black.

Yepp and thanks for all your good help.
After some while some widgets fall out of the screen. A screen refresh brings them back.

That bug has a fix waiting for release. Most likely tuesday or wednesday.

Hi Bob,
I am going to start again from scratch - Is there a way I can save all the blocks on the spark into a txt file or something - as a reference for when I blow away all the block?

Admin page → spark service → backups. You can download the latest there.

If the UI is not cooperating, you can also get the files at the brewblox/spark/backup/{service}/ directory. They’re json files with the date in the name.

Hi Bob,
I can see how to export a layout, but I am not sure how to import one, please can you advise?
Many thanks

Open the Builder editor, and click on the three dots in the top right corner. Under “Builder actions”, there’s “Import Layout”.

We’re aware that it’s somewhat hidden. A rework of import/export UX is on the todo list.

Thanks bob, that worked fine

Hi again Bob,

Today I am not able to contact my system with SSH.

ssh pi@ worked

Hi again

After the 2023/05/30 update my actions widget has some “problems”. When I select disable or one of the profiles, the field goes green. When I select one of the constant temp. fields there is no green. I think it works ok.

The action is green when applying it would not change anything. When you hover over the constant temp action, what does it say it would change?

Is this one readable?

The green is pretty vague, but it looks like it thinks 68.00 C != 68.00 C?

This setting comes up with 20°C as preset and I reset it to 68°C.

I tested a bit more. Const. MT has a stored setting 20°C. When I don’t change it, it comes out green. When I change it (= another setting than the stored one), it doesn’t go green. So I set my stored setting to be what I want and it turns green and works. However, I can’t say I understand what’s happening.