Remote Access to Brewpi Spark

I know it’s been topics about this, but i have a hard time knowing where to start.
My problem is that i can’t see/access the userinterface when accessing from remote. On top of screen it says: "SSh-2.0-OpenSSH_6.7p1 Raspian-5"
Any good suggestions on what to do to get the userinterface up and running from a remote location. Works well from local. I am not good at programming, but learning as i go:-) Thank’s
Just to add, i am using Airport Extreme router(tower model)

Have you read through this and the links to the Home Brew Forum?

Also, do you have your BrewPi running and can you view the web UI locally already?

I can probably help you through this part of it as I just set up remote access this weekend.

Yes, i have looked at that, but i can’t get much out of it. My brewpi is running perfect, UI is no problem locally and i suppose that i get some sort of connection from remote when the text i my first post pop’s up. Just can’t understand what text it is trying to tell me:-/

Could I ask what URL you are using to get to the Pi?

So you followed all those instructions from the HBF? You cannot access the BrewPi remotely if you have not, from my understanding.

rbpalmer-i am connecting direct to my public ip with port 8010 forwarded(i know it’s not secure)
bryancm1- no i didn’t because i had a hard time knowing what the problem is, i have some kind of connection but as previously posted, i don’t get what that text mean.

interesting, I assume that you are on the latest version of Raspbian (Jessie)? I am just upgrading to this to see if I get the same issue. So far not though.

So you can access the web UI by typing in the pi’s address into a browser but cannot access the web UI remotely? I’m probably not good at articulating this stuff as I barely understand it myself but I use a different ip (my home’s) in the address bar when I access remotely. For instance, if at home on same network I just put in the static ip for my pi 126.198.0.xx etc. but when away, I use or something like that (whatever I found my homes router to be). Is that what you’re doing?

Or are you trying to ssh into your pi remotely?

rbpalmer- yes i have the latest
bryancm1- yes that is exactly what i do. Works like a charm local. I also use WebSSH from my iPad to get to my PI from time to time and that also works perfect(local only)

Hmm. Hard for me to know then. Maybe someone else can chime in. Possibly a port forwarding thing on the modem/router? I know I could access the UI perfectly after setup and it worked great. It wouldn’t allow me to access the UI remotely though until I followed those other instructions. Sorry I can’t be more help.

When I went through this kind of setup, I learned (the hard way) that I need to actually be on a remote network to hit the externally-visible address. If I try the external address when I am on my internal home network I get a 404 error; apparently my IP packets aren’t smart enough to know they need to go outside the firewall only to come back inside it.

Yes, i know. To test remote connection i use the 4G mobile net. I also get the error when trying to login remote from local.

Hi @hankai, firstly, I don’t own a brewpi or a spark/arduino but am very keen to join the ranks soon. My info here my not be applicable as I can’t test… :-/
What is your external port forwarded to? Sounds like it is set to the SSH port (22) instead of Web (80) or ssl (443). This assumes you want to point a Web browser at it. If you want to point a SSH client at it then forwarding the port to 22 should be fine.
So, to summarise…
Forward the port to 22 if you are using webssh to connect. (assuming you can set webssh to a non standard SSH port)
Forward the port to 80 or 443 to get a Web browser to connect.
(you could even set up two port forwarding rules, one for SSH and one for Web)

This all assumes you don’t have any other firewalls in between the brewpi and your remote location that are causing grief.

Good luck!

Thank’s for input. Still no luck. My router adress from outside is 80.198.—.–
My public external/public port is set to 8010
My private port is set to 443
Brewpi ip is 192.168.-.-
Is this the way to go, or…??
I might better start to program using the guide from earlier reply, but i must wait to my fermenting beer is finished.

Ah righto. Can you confirm the url you are typing in?
Is it just “80.198.—.–:8018”?
Which then redirects to "192.168.—.---:443"
This doesn’t tell your browser that it is using the ssl protocol…
Try manually typing “https://80.198.—.–:8018”

What do you normally type in when accessing locally?

Cheers, Scott

Yes it is. The 8018 port did not work. I just type in the ip 192.168.—.--- in Crome browser and boom i am into Brewpi locally.
Thank’s for trying to sort out my lack of understanding:-)

Arrrr, sorry. i meant to say https://80.198.—.---:8010
i made a typo earlier by saying 8018

so can you try https://80.198.—.---:8010

cheers, scott.

Hmmm, thinking more now…
what is the default protocol used for BrewPI webpage?
is it SSL (https://192.168…) or normal (http://192.168…)

sorry, not having one I don’t know if it uses SSL or regular

if you just type 192.168.x.x into your web browser locally then your port forwarding should be set to 80, not 443.
why is it that you had 443 in the forward rule on your router?

try setting your port rule to point towards 80 and see how you go

IT WORKS!! Thank’s for det help. It was the 80 port that was the solution, my bad. Next is setting a password, and that is another story…
Elco— Is it possible to make password setting an option in the settings menu on the brewpi? It will make life a bit easier for a non programmer as me.

1 Like

Ah nice one.
I’d probably recommend that you look into a better setup for your router though…

Some affordable next gen routers are available with very easy to setup VPN servers that will put you inside your home network from anywhere. No port routing, firewalling issues or security holes. You get an openvpn client to install to install on your pc / mac or mobile device (android / IOS) and you’re away.
also works wonders with geoblocking :wink:
All budgets have a limit, but when you’re punching holes in your firewalls, you’re kinda playing with fire.
Cheers, Scott