Set Temp Probe Resolution?


#1

Is there a way to set the resolution of the temperature probes? One of mine seems like maybe it is at a lower resolution than others.


#2

Our firmware picks the highest resolution.
Where did you buy the sensor? What is the part number? A lower resolution exist but is not common.


#3

They came with my fermenters along with 1 BrewPi Spark 2 second hand. I ordered a second Spark 2 from you. My understanding is everything I got with my fermenters came from you but that could be wrong and no guarantee they were ordered at the same time as I believe the previous owner had a previous gen Brewpi as well.

See this thread regarding the problem I’m trying to solve: 1 Brewpi Controlling nicely, one missing targets

One difference I noticed is this one seems to only have 0.11F resolution. I’ve swapped the actual vessels, including the heater and the “good” brewpi system works with the “bad” tank so its something about the Brewpi. I’ve reflashed the firmware already and that didn’t make a difference. I’m wondering if the seemingly low res probe is confusing the control alogrithm?


#4

0.0625C (0.11F) is the maximum resolution of the sensors.

In a very old version, the chart displayed filtered temperatures, but the latest version displays the actual sensor temperature. The filtered version might seem to have a better resolution.

Did you upgrade the firmware of both of the BrewPi Sparks to 0.5.10?


#5

The “good” one is at 0.5.9. I thought I updated the “bad” one but it reports 0.5.2 so I need to try the upgrade again.

Where can I find solid instructions on the firmware upgrade. Obviously I did something wrong there.


#6

The most error-proof way is to update over usb with the following 2 commands:

docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-raspbian python utils/flashDfu.py --trigger

docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-raspbian python utils/flashDfu.py --noreset

The photon will have to pull an updated bootloader from the Particle cloud, which requires that you set up WiFi using the Particle iOS/Android App. If you don’t have the right version of the bootloader, the photon will blink blue until you connect with your phone and configure WiFi.


#7

OK, got both updated to 0.5.10, running a new test on “bad” (and starting a brew on “good” so hoepfully I didn’t screw it up.)


#8

That didn’t help at all. Brought it to 62 with the chiller, then started a 1 day, 10 degree ramp. Its currently almost 1.5 degrees behind. The “good” one can do that no problem. I chose to retain settings when flashed, I think I’ll flash again to 0.5.10 without, set it up again, and see if that helps.


#9

You can also reset to factory defaults at the bottom of advanced settings.

If you can post a screenshot of the chart I can analyse it.


#10

Hopefully this works since I’m on my phone. I’ve not had time to do a reset yet but I’ve done that in the past though. Chart


#11

Looks like you are running with a direct heater (no fridge). Try this:

Set kp for beer to fridge to zero.
Set heater1 kp to 50, so for 1 degree too low the heater is 50% on.


#12

Beer to fridge kp is at 0 and heater 1 kp is already at 60.


#13

OK, after MUCH consternation I finally reset and reloaded the firmware. I got a black screen and ended up doing a reset with the particle device doctor, then had a lot of trouble getting the update to install, but FINALLY did.

Starting a new ramp test now to see if there’s any improvement.


#14

Did you verify in the logs or at the boot screen of the Spark that you are running 0.5.10?

The black screen is probably because your bootloader was not up to date. The firmware needed to download an updated bootloader from the Particle cloud, so it required that you have set up WiFi on the Spark with the phone app.


#15

It definitely said 0.5.10 after the previous attempt when I’d told it to keep settings and configuration. But when I did it again it worked until the restart.

Not very far into the test, but so far it looks promising. We’ll see what it looks like in 12 hours.


#16

This is looking much more like I’d expect.

Looks just like the beer I’m currently brewing that went into a 2-day ramp at about the same time.


#17

Yay! Good to hear you finally resolved your issues. Happy new year :slight_smile:


#18

I think we can call this one resolved by a full reflash of the module without retaining settings. The last test looks exactly like I’d expect.