Software Install Guide

Great! I look forward to some early adopters fleshing out the user documentation for us.

Please include lots of pretty pictures :smile:

BrewPi Spark install help.

I’ll admit, I know much less than I would like, and I’m willing to learn, but I can’t find where to start. I have a RaspberryPi set up with BrewPi and my BrewPi spark just arrived, but I cannot figure out how to set it up. The screen currently displays a hardware test and has no problem reading the sensors, but when I try to set it up on the dashboard, I get an error “Error while receiving device configuration: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data”

I have no idea where to go or what to do, and I can’t find it in the community.

Any help would be greatly appreciated, and thank you in advance.

Theres a good bit of updating to do for the Spark to connect. Did you update the BrewPi software?

Hi everyone,

I just received my Brewpi Spark and I’m having a hard time making it work.

  1. Couldn’t get a Core ID via Node.js so I went for factory reset. I could then connect the core via Node.js but the LCD was white so I reinstalled Brewpi firmware (thanks to this guide Spark setup problems [SOLVED]).
  2. Now I’m back to Hardware Test page but Spark Core is not connected anymore. How exactly do I configure Brewpi to access the GUI?

When I use putty via COM I can’t type anything without getting some log:

The LCD screen on the Brewpi shows Hardware Test page and If I snuck a temperature sensor I can see It get recognized and shows temperature.


I did as much as I know how.

I get this far, and then I’m at a loss:

The update script can automatically check your Arduino version and program it with the latest hex file from the BrewPi server, would you like to do this now? [Y/n]:y
Stopping any running instances of BrewPi to check/update hex file…
Your version of pstuil is 0.5.0
BrewPi requires psutil 2.0 or higher, please upgrade your version of psutil.
This can best be done via pip, please run:
sudo apt-get install build-essential python-dev python-pip
sudo pip install psutil --upgrade

pi@raspberrypi ~ $ sudo apt-get install build-essential python-dev python-pip
Reading package lists… Done
Building dependency tree
Reading state information… Done
build-essential is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 47 not upgraded.
pi@raspberrypi ~ $ sudo pip install psutil --upgrade
Cannot fetch index base URL
Could not find any downloads that satisfy the requirement psutil in /usr/lib/pymodules/python2.7
No distributions at all found for psutil in /usr/lib/pymodules/python2.7

@Alessandro: we disabled spark cloud functionality because we need the extra space and because we have a local server. It is normal to not be able to access the core via the Spark Cloud.

You have to connect the BrewPi Spark via USB. I see that you are connecting to COM5, so you’re on Windows.
On Windows, you’ll have to manually start the python script and configure the config files so the web interface and python script can find each other. More info is given is this thread:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data"
That’s just the error you get when the script is not running at all, we should add a better error message when people try to receive devices but the script is not even running or does not respond at all.

Are you sure you have an internet connection and can resolve DNS? It is strange that you cannot find the psutil package via pip.

Also, please skip updating the spark core in the install script, it is not implemented yet. I am fixing that this week.

Im having some trouble connecting the spark over usb as well. Do I have to connect to my mac first to configure it with a program like cool term? or can i connect via ssh on my terminal?

The spark is connected to the raspberry pi via usb. As soon as you connect it it should power up.

You communicate to the spark through the web interface, which is run by a server on the raspberry pi. Does this help at all?

unfortunately is does not. the web interface says it cannot run the script. im unsure if i need to assign a hex or claim the spark or anything else i missed

Hey Robert. Are you using the RPI? If so have you updated the BrewPi software? The update allows the RPI and Spark to communicate over a serial port. I see it says script not running, have you tried starting the script? (By clicking script not running)

Check if the device is actually seen by the Pi: ls /dev/ttyA*
Another user reported that his USB cable did not make contact with the data pins, but did power the device. He had to push it in further to get a serial port.

You can also come to and click chat, I’ll help you out.

i have almost certain i updated the pi but i cant try up update it again its possible i missed a step. and yes i did click on the run script button and it does nothing. it doesn’t recognize any devices either.

This is what comes back when i type that command in

/dev/ttyACM0 /dev/ttyAMA0

i wont be able to check the cable until tonight though. I’m hoping this is the case.

Okay, looks like you have a serial port. What do the log files say? Why is the script not starting?

got it to work, i need to reinstall and update everything again

I’ve reset my Spark and I’m trying to install Brewpi on windows using COM5:

  • If I run I get this error
Traceback (most recent call last):
  File "", line 335, in <module>
    if os.geteuid() != 0:
AttributeError: 'module' object has no attribute 'geteuid'
  • If I run I get

Error opening serial port /dev/ttyACM0.
(could not open port ‘/dev/ttyACM0’: WindowsError(3, ‘The system cannot find the
path specified.’)):
Error opening alternative serial port /dev/ttyACM1.
(could not open port ‘/dev/ttyACM1’: WindowsError(3, ‘The system cannot find the
path specified.’)):

It’s been now a week since I’ve completed and successfully tested the refrigerator. The only thing that’s keeping me from brewing is the configuration of Brewpi :cry:

Hi Allesandro,

The update script is really meant for use on a Raspberry Pi, or at least Linux.
On Windows, there is no such thing as UID (linux user’s id, coupled with permissions).

You will have to update the web interface and python scripts yourself by doing a git pull.
Sourcetree is a visual client that might help you with that.

To update the controller, you can run from <script dir>/utils


It was just me being dense: I was trying to install the software on the Arduino. I am now able to brew some beer.

Thanks Elco!

Had some issues connecting my Edimax wifi dongle to my AP which was using a hidden SSID.
Solved it after a bit of googling by adding the following to my /etc/network/interfaces

wpa-ap-scan 1
wpa-scan-ssid 1

This also works using a wpa-supplicant conf file with ap_scan=1 and then scan_ssid=1 in the network section. Hope this helps someone, now to finish my fridge and get brewing

Just found out that the latest images (at least the NOOBS image) comes with zeroconf pre-installed.

The raspberry pi will announce itself as raspberrypi.local on the local network. Messing with static IP address is therefore not needed. I have updated the guide.

1 Like