[solved] Device setting not saving - BrewPi not saving sensors - HELP


Generally nothing is that important but I have 10 gallons of Kolsch cooling right now and my BrewPi isn’t working again. I can go to the Maintenance Panel and set it up but the settings don’t save. I am hitting apply too.

I will do this:

and then refresh and see this:

Not installing devices? Any help would be appreciated.

1 Like

I ran:

sudo echo 'E\n' > /dev/ttyACM0

I’m not entirely sure what it did but now everything is working again.

That command (‘E’) reinitialises the EEPROM.

Just for my own educational purposes, why do you suppose that needed to be done? I did have it completely unplugged for several hours. Could that cause a situation where the EEPROM needs to be reset?

Sorry, I don’t really know. Anything I suggested would be pure speculation.

I know what the command does because I looked at the source code. I am curious how you decided that that command was necessary, and how you knew how to issue it. Is it documented somewhere?

@ame, dumb luck. Seriously. I found something about it here:

I did all the updates and it just wasn’t working. It was running fine but then I had to dissemble some things and it set without power for 6 hours or so and then when I reconnected it my setting were erased and not saving. I decided to just give it a try. I was sitting there with a bunch of beer in a conical that needed to be kept at 60F and was in a panic. Its working perfect once again and I’m not messing with anything.

Well, basically it resets the data in the EEPROM, so if there was any dud data or inconsistent data (from whatever cause) it would be cleared.

Glad to hear it’s working well again.