Spark 2 on debian 10 (buster)

Hello everyone, I installed on rp 3b plus, debian 10 (buster) I followed to the letter the tutorial brewpi but arrived at the command to install docker comes out the problem. Docker is not installed and therefore I can not proceed with the creation of portainer. Also for a few days I have the led on the spark that flashes green (internet search) I tried to connect with particle to set the wifi led flashing blue, the smatphone finds the photon but does not connect. The screen always remains on connection in progress, I waited over 10 minutes but nothing happened and I had to restart the smarthone. Someone can help me thank you.

Docker still has not fixed their install script for buster.

Can you try the suggestions in this thread?

1 Like

No I didn’t try, i’ll try this afternoon. And what do you recommend for the photon?
Thank you

Use the brewblox-ctl wifi command once installed.

1 Like

Hi, now I have a little dilemma. But will brewblox replace brewpi?
If I install brewblox now can I go back to brewpi?
Thank you very much.

BrewBlox is a full replacement for BrewPi, but the Wifi command uses a tool from Particle, and can also be used for BrewPi.

You can run it with

docker run -it --rm --privileged brewblox/firmware-flasher:edge wifi

Beyond that, you may want to consider upgrading to BrewBlox anyway: it’s a big improvement over BrewPi.

Does anyone know if Docker is supported on Buster yet?

As far as I know: yes.

Great, thanks. Just received Pi 4 and ready for a fresh install!

  • sudo -E sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Command ‘curl -sL | sh’ returned non-zero exit status 100.


Could the new docker build require a different command?

E.G.: curl -fsSL -o

Tried a fresh install and went to install docker before running the ‘brewblox-ctl install’.
Received a similar error message:$ sh

Executing docker install script, commit: 6bf300318ebaab958c4adc341a8c7bb9f3a54a1a

  • sudo -E sh -c apt-get update -qq >/dev/null
  • sudo -E sh -c apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
  • sudo -E sh -c curl -fsSL “” | apt-key add -qq - >/dev/null
    Warning: apt-key output should not be parsed (stdout is not a terminal)
  • sudo -E sh -c echo “deb [arch=armhf] buster stable” > /etc/apt/sources.list.d/docker.list
  • sudo -E sh -c apt-get update -qq >/dev/null
  • [ -n ]
  • sudo -E sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null
    E: Sub-process /usr/bin/dpkg returned an error code (1)

What happens if you follow the install guide and out our installer install docker?

I did - it won’t and gave the first error message

I’ll run a buster install today, as this is a new issue (you’re already past the two initial problems with docker for buster).

Cool. I don’t think it’s brewblox related actually, didn’t install any of your software. On the second/third try just a fresh install of raspbian lite/desktop, followed your install guide until the brewblox install script and then tried the install docker.
Searched online and I do think it’s possible to do, if I’m correct there should be a stable docker release for buster.
However, I’m no expert and everything I try should be double checked :slight_smile:

From your posted logs, it indeed doesn’t look like a BrewBlox error. Given how the Pi is our primary platform, it’s still useful to be aware of errors installing an important dependency.

I’ll do a new install again as well and try to post things clearly, later today.

Looks like it is installing now. Formatting the sd card using sd card formatter did not work, it gave an error. Formatted with diskpart instead which was succesfull. Installation now underway and looks good!
Should have tried that earlier, i assumed etcher did that for me. Maybe add a formatting suggestion in the guide for guys like me, always good to start with a clean SD card.

I also was under the impression that Etcher formatted the SD card. I’ll look into it.

1 Like

Having issues installing Docker here. Workaround seems possible, but it’s definitely not yet working out of the box.