Spark 3 randomly rebooting

I searched through the other rebooting topics on the forum and didn’t find anything that applied. I’ve had issues with the Spark 3 randomly rebooting, usually once a day or so. Afterwards, the beer temp gets a bit erratic but finally gets back in line, only for the same thing to happen again the next day. Had just gotten home from work and heard it reboot, so I ran the log command.

Just got another reboot a couple of hours after the previous one.

Thanks for the report! We’ll try and figure out what’s going on.

Not sure if it’s related or not, but this morning the Spark 3 had lost it’s IP address as well.

It’s likely. We recently fixed a different bug, but that was caused by blocks you’re not using.

When I came home, I unplugged the Spark 3 for thirty seconds, plugged it back in and the WiFi is up. I performed a clean install of BrewBlox and will see how that goes with the rebooting issue. While I was going, I added my Tilt in and that is working fine as well.

I looked at the Spark 3 this morning and it still has an IP address and after looking at BrewBlox, there is no evidence of a reboot after the fresh install.

Not sure it’s related, but mine just rebooting three times in the space of ten minutes. I remember it used to randomly rebooted a lot a few months ago but an update seemed to fix the issue. Not sure if this is a regression or a new issue.

Just did it again. It’s seems to be rebooting exactly every 4 minutes.

If possible, could you please run an update? If not, could you please export your blocks?

We solved a few bugs since the release you’re using, and we added a block dump to the brewblox-ctl log output.

@blkmagik98 Please let us know if whether it has or hasn’t rebooted again after a few days. It may be an incidental issue, but could also be a rare-ish bug that corrupts persistent objects on the Spark.

Will do…it’s been up now for over 17 hours with no issues. Probably coincidental, but adempewolff is getting reboots every 4 minutes and mine was every 4 hours to the minute.

Was almost connected 22 hours when I came home, but the Spark 3 had lost the WiFi connection again. I tried to reconnect it through the web interface with no luck and after I tried a couple of times, it did reboot on its own. Now I’m getting this screen with the occasional pop up message Failed to discover objects on spark-one: bad gateway.

Here’s the log generated-

The Pi seems to be making connection over USB.

You can try to use the Wifi connection by setting --discovery=wifi or --device-host=SPARK_IP in the docker-compose.yml file (, and then running the following commands:

docker-compose stop spark-one
docker-compose up -d

Alternatively, you could go the other way, and clear the wifi credentials. To do so: hold down the setup button for 10 seconds until the LED rapidly blinks blue.

A fixed WiFi channel also seems to help. If the router switches channel, the Spark will temporarily lose its connection.

Hand picking a channel for every access point in your house to make sure the channels don’t overlap is a good idea anyway. I use a WiFi analyzer app on my phone to see the available channels and other networks in the air.

The default on most routers is to auto switch between 1, 6 and 11. If there are no other networks interfering, I prefer to use the too, but manually set on each acces point so they don’t jump around and don’t overlap.

I like this one:

Unfortunately the router that I have doesn’t have a channel change feature, but I use the same analyzer and have never seen it use a different one.

I left the USB connected due to it dropping the WiFi as I would still be able to connect to it through if I am away from home. I’ll do some experimentation with your suggestions and see how it works though. Thanks!

The Spark service has now been up for 24 hours, still has an IP address and has had no issues.

1 Like

What did you change?

I had previously been running Buster with a workaround using Docker for Stretch. I removed Docker, deleted the BrewBlox directory and then completely reinstalled Docker and BrewBlox. No issues since and I didn’t use the workaround this time.