Still cooling even though past beer set temperature


First time using the new BrewBlox for an actual beer. I brewed yesterday, then put my wort in the fridge to chill to pitching temperatures (9°C). I checked this morning, and BrewBlox appears to be showing that it is still chilling, even though the wort is 2°C below the set temperature and the fridge chamber temperature is at 3.5°C…

Any ideas what is going on and how I can fix this?

Graph plot:

Fridge view:

I am a bit confused about the Cool PWN value. Surely a fridge is just on/off - how does a PWM make sense in this case?

One thing I noticed while taking screen grabs for this, the ferment actions pane seems to indicate that control is not enabled. However it was set to constant beer temperature previously (as otherwise it would not be cooling).

Any help appreciated!

Take a look at the cool PID graph. I think the integrator time constant Ti is too low, causing the integral to grow too quickly.

Increasing Td might also work to slow down the approach.

The pwm for the fridge has a 30 min period, it is slow pwm. Also make sure you update to this week’s release. It has some pwm improvements.

Thanks for your reply. Not sure I understand what you mean, pretty much a novice at how all this stuff actually works.

I added a graph for Cool PID:

But not sure what it all means.

As for the Td setting, I have to be honest that I am not sure how to do this, nor what to set it to.
[EDIT: I have managed to find where to set this - just clicking on the snowflake icon section of the fridge view - pretty obvious! I am still not all that certain what to set this to…]

Still not sure I understand why BrewBlox is still cooling over 3 hours after the wort went below the set temperature.

Something is wrong. The integral should not increase if the output is at 100%.

Can you export your blocks on the spark settings page? (Top right menu)

On the PID widget you can reset the integral to stop it from cooling now.

Thanks, Elco.

I have exported the blocks: brewblox-blocks-spark-one.json (5.8 KB)

As to the comment about resetting the integral, I am not sure. I went into the Ferment Cool PID, clicked on the value for I on the right side of the integral line and set to 0. Is that correct?

Sorry, missed this comment. I am on the update from a couple of days ago. Edge release 2019/08/22

Ah I misread your chart.
The P value is decreasing in your chart, but the I value is increasing at the same rate, keeping the output at 100%.

You have a Kp of only -10. That means that your output is only 10% if the temperature is 1 degree too high. Because this won’t do much, the integral starts to build up to compensate. The integrator is a slow mechanism that slowly increases, but also slowly decreases. This caused the overshoot.

If you increase Kp to -50, the output will be directly proportional to the error a lot more and the integral will only start to do something if you are much closer to the setpoint.

Thanks! I will try that. I have set the cooler Kp to -50. I will see how that goes.

The heating Kp was 20 - I have set to 50, is this a good idea, or should I leave at 20?

Thanks again for your help!

Make an estimate yourself: at which difference between setpoint and measured temperature should the actuator run at full power? Your Kp is 100% divided by that.

Don’t forget that for a cooler Kp should be negative.

In the step view there is no active step?

Yes, I commented on that above. I think that may be a UI issue. The constant beer temperature step was showing as active last night when I looked, but not today even though it still was controlling. In the ferment fridge widget, when I clicked in there, the target temperature was displayed.