Trouble flashing spark 0.2.7 and now 0.2.6 does not load [SOLVED]

I followed the instructions at but the console log in the web interface reported “Problem flashing file: 78”. At this point the 0.2.6 firmware seems to be working fine, it boots and displays my temp probe readings.

Ok, no problem I will follow the instructions at Flashing a Spark Core you bought elsewhere or in case of emergency

This instructs me to put the spark into DFU mode. I tried following all three sets of instructions listed below with no luck. dfu-util 0.7 never could see the device. It never blinks yellow. I can peer into the usb port and yellow just does not happen. Now it is blinking blue when I power it on and instead of the of the 0.2.6 firmware display it just boots to a white screen.

Can anyone tell me how to recover my device?

Thank you very much.

Methods that I tried to enter DFU mode:

Put your spark core in DFU mode. This is done by resetting the device while holding the mode button until you see a yellow LED flashing. With the Spark Core being inside the enclosure, this is a bit harder.
There are two holes in the bottom. When looking into the USB connector, the right hole is above the mode button and the left hole is above the reset button.
Hold down BOTH buttons
Release only the RST button, while holding down the MODE button.
Wait for the LED to start flashing yellow
Release the MODE button
The Core now is in the DFU mode.

Put you Core into the DFU mode by holding down the MODE button on the Core and then tapping on the RESET button once. Release the MODE button after you start to see the RGB LED flashing in yellow. It’s easy to get this one wrong: Make sure you don’t let go of the left button until you see flashing yellow, about 3 seconds after you release the right/RESET button. A flash of white then flashing green can happen when you get this wrong. You want flashing yellow.

Hi @Marty!

Sorry to hear of these troubles. Here’s some troubleshooting thoughts:

  • Did you try flashing 0.2.7 several times? Does it always fail with the same message?
  • dfu mode is tricky - and I would urge you to avoid this if possible. I’m sure your device has it, but getting it there can be hard - mechanically hard since we don’t have easy access to the buttons. I find the easiest way is to to hold in the mode button (the one on the left, with the buttons at the 12 o’clock position) and then plug in the power to the device and keep holding. 3 seconds can be 4-5 when counting!

So forget DFU, at least for now.

Try the upgrade from the web UI again and we’ll focus on getting that to work!

Thanks for the reply @mdma. I was successful!

I did have to go back and continue to attempt to put the spark into DFU mode. I made attempts with the web application a few more times, and switched back to master from the develop branch. But once the spark was in the mode where the blue light was flashing (due to all my unsuccessful attempts at putting in it in DFU) every flash attempt via the web ui was resulting in “Problem flashing file: 78”

What worked for me was putting the case lightly in a vice with the back facing me. Then while watching the video at to make sure I had the proper orientation I used two short lengths of rigid wire to press the buttons. On my second try using the vice to hold the unit steady I was able to trigger the flashing yellow light. After that dfu-util 0.7 loaded the firmware without issue.

Excellent! Yes the mode button must be pressed when the device powers on - if it’s pressed even a few milliseconds later then the device will boot normally and then enter setup mode (flashing blue led.)