Updated to 4/06 release, now spark is in a SOS reboot loop

Hi, I just updated to the 4/06 release and now my spark 3 is rebooting every 25-30 seconds.

The screen comes up fine with the correct temperature in Fahrenheit, but it does the red LED SOS signal and then reboots.


Same here. I don’t even get as far as the temperature screen, it’s just stuck in a reboot loop.

Can you try giving me aan EEPROM dump, so I can get an exact copy of your Spark?

docker pull brewblox/firmware-flasher:edge
docker run --privileged -it --rm -v /dev:/dev brewblox/firmware-flasher:edge trigger-dfu
docker run --privileged -it --rm -v /dev:/dev -v /home/pi/brewblox/:/dump -v /dev:/dev brewblox/firmware-flasher:edge -c "dfu-util -d 2b04:d006 -a 0 -s 0x800C000:0x20000 -U /dump/eeprom.bin"
curl https://bashupload.com/eeprom.bin --data-binary @/home/pi/brewblox/eeprom.bin

Doing that right now, but I got the following message and it’s now downloading images:
Unable to find image ‘brewblox/firmware-flasher:edge’ locally
edge: Pulling from brewblox/firmware-flasher

I assume I need to connect the spark via USB for this to work?
I got the following error codes:
Triggering dfu on port /dev/ttyACM0
[Error: Error: No such file or directory, cannot open /dev/ttyACM0]

dfu-util: No DFU capable USB device available

I’ll try that later, the RL is requiring my presence… :-/

Yes. DFU is over USB.

Did you update to the latest version over WiFi?

Yes, latest version was over WiFi.
I will try USB later.

I tried above commands (and re-flashing via brewblox-ctl) over USB.
The system discovers the spark just fine:

INFO Discovering devices…
usb 40005a000851353532343835 P1
INFO Done!

…but when trying to flash (or pull the image), I get this error message:

Triggering dfu on port /dev/serial/by-id/usb-Particle_P1_40005a000851353532343835-if00
No compatible USB devices found

I am having the exact same problem. When I try to flash I get this and it continues to power cycle.


By putting it into DFU manually I managed to get it to flash but still going straight back into a reboot loop when its done.

Elco got an EPROM dump from my Spark and is currently looking into it.

No worries, is there a way to go back to previous version of firmware until it is sorted?

Building previous version now. Whether that or a fix gets pushed live depends on how long the fix will take.

Roger that, a good lesson for me to not run updates while there’s a beer in.

1 Like

This bug was my fault, sorry! A fix has been released.

You may need to trigger DFU mode manually to flash over USB, because automatic DFU triggering before it crashes is not possible.

  1. Hold the setup button (right of the spark, top hole) with a small pin.
  2. (Re)boot by pressing the other button or plugging in power
  3. Release the setup button when the LED starts blinking yellow.
  4. Run brewblox-ctl flash

P.S. If you have not done so, also run brewblox-ctl update, otherwise the UI will tell you to flash the firmware because the controller has a newer version that doesn’t match.

1 Like

Awesome, back up and running again. Thanks guys

1 Like

Fix worked, thanks guys!

1 Like

Flashed and works! Thanks for the quick fix!

If you’re ever in the area of Utrecht, let me know, I owe you at least one bottle of homebrew!

Thanks for the steps to flash over USB, that fixed both of my sparks.

One is at firmware version ee18c7d6 / 2020-04-07 and the other is at cd4009c5 / 2020-04-02. Both have been stable for the last 15 minutes.

Will hold off on updates for a while. :slight_smile:

Thanks for your support

You should be able to update your 2020-04-02 one too, so they both run the same version.
We’ll try to give the next update a bit more testing.