White screen Brewpi - Troubles after moving to docker


#1

Hi
I have run into some troubles after trying to installing a fresh Brewpi on docker.
I do not have much experience in RaspberryPi/programming/working with terminal, but the previous installation of Brewpi and Raspberry Pi went OK.

So what I have done:

Other things that I have tried:

  • Installing old Raspberry Jessie hoping that I was able to connect spark in DFU and run brewpi commands (some commands seems to be outdated because of the migration to docker?)
  • Flashing spark through windows
  • Reinstalling Hyperion thinking that some were wrong with the installation

I have managed to get the Brewpi in DFU but it can not be recogniced when using the guide and so I have not manage to flash new firmware on it:


when running flashDfu.py I get this, (Spark was flashing yellow DFU when I ran the command):

I think docker is running OK:


But when i press the Published Ports link it takes me to web page “http://0.0.0.0:9000/”, and when I enter the IP adress directly 172.17.0.3:9000 it shows nothing/web page is not available.

So I am sitting here with a raspberry with a fresh installation of Hyperion, connected to WiFi, portainer is installed as the webpage above. I am really scratching my head over here and my IPA is fermenting on 16C! :roll_eyes:

All help is deeply appreciated. Thanks.


#2

Small update on this. Still trying to flash something to the spark in DFU:


#3

I am also getting this:
pi@raspberrypi:~ $ sudo python /home/brewpi/utils/flashDfu.py
Traceback (most recent call last):
File “/home/brewpi/utils/flashDfu.py”, line 204, in
dfuUtilVersion = re.search(’(?<=dfu-util\s)\S*’, output).group()
AttributeError: ‘NoneType’ object has no attribute ‘group’


#4

This is a bug in portainer, it shows 0.0.0.0 instead of the pi’s address.
You say when you go to 172.17.0.3:9000 directly, it shows a blank page, but you are showing a screenshot of portainer (which is on 9000). That IP address is an internal address. The external port 9000 is mapped to that container. So just use the address of the pi.

Now on to your flashDFU problem.

Did you start the docker container privileged so it has access to the DFU device? See these instructions on the wiki:
https://wiki.brewpi.com/getting-started/updating#updating-the-brewpi-spark-firmware-with-dfu


#5

Hi Elco
Many thanks for your reply! I also got some help on the particle: https://community.particle.io/t/flashing-brewing-firmware/36989/2
Thanks for pointing out the bug.

So I managed to flash the BrewPi with firmware from Git. So the status now is “script not running” and the log in the maintenance panel shows

Error while receiving device configuration: SyntaxError: Unexpected token C in JSON at position 0

I also tried to run the updater as you suggests and got:

I will try to flash again when Brewpi is connected Raspberry later today and see what happens.


#6

The flashing command /DFU worked fine but did not change the script not running and the
cd ~/brewpi-tools
python updater.py
Does not seem to work:

Checking whether the update script is up to date
/root/brewpi-tools is up-to-date.

It is not recommended to update during a brew!
If you are actively logging a brew we recommend canceling the the update with ctrl-c.


*** Updating BrewPi script repository ***

Stopping running instances of BrewPi
[Errno 111] Connection refused
Could not connect to socket of BrewPi process, maybe it just started and is not listening yet.
Could not send quit message to BrewPi instance with pid 3153!
Killing it instead!
SIGKILL sent to BrewPi instance with pid 3153!
You are on branch master
The latest commit in /home/brewpi  is 2b3756d43988264c73be8a42fe39ee01285cec8e on Mon, 31 Jul 2017 22:01:57
The latest commit on origin/master is 2b3756d43988264c73be8a42fe39ee01285cec8e on Mon, 31 Jul 2017 22:01:57
Your local version of /home/brewpi is up to date!


*** Updating BrewPi web interface repository ***
You are on branch master
The latest commit in /var/www/html is 2282837df5f0bb171ae58302b7780d5d50d213e2 on Sat, 23 Sep 2017 10:23:28
The latest commit on origin/master is 2282837df5f0bb171ae58302b7780d5d50d213e2 on Sat, 23 Sep 2017 10:23:28
Your local version of /var/www/html is up to date!

No changes were made, skipping runAfterUpdate.sh.
If you encounter problems, you can start it manually with:
sudo /home/brewpi/utils/runAfterUpdate.sh

The update script can automatically check your controller firmware version and program it with the latest release on GitHub, would you like to do this now? [Y/n]:y
 Stopping any running instances of BrewPi to check/update controller...

Checking current firmware version...
 Oct 28 2017 09:17:39   Opening serial port
 Oct 28 2017 09:18:10   Errors while opening serial port:
Could not open port socket://192.168.10.187:6666: [Errno 113] No route to host

 Unable to receive version from controller.
Is your controller unresponsive and do you wish to try restoring your firmware? [y/N]:
y
 Could not find compatible device in available serial ports.
Firmware update done


*** Done updating BrewPi! ***

Please refresh your browser with ctrl-F5 to make sure it is not showing an old cached version.

#7

If you are upgrading to 0.5.3-rc.3 from 0.5.2, you should also update the system firmware included in the release. If you have a blue LED, this can be caused by a mismatch in system vs application firmware version.

In total you need to flash 3 files, system first. Then Goe through wifi set up with the Particle phone app.


#8

Hi again.

I have done the upgrade of all three files in that order. I have been able to connect it to internet with the app, but the ligth breathes green and I am no longer able to connect to it through the app. If I try to “Set up photon” through the app again, some times I can get it through the wizard, some times not and the indicator light switches to either breathing white or breathing green.

Could it be something wrong with the spark/photon wifi hardware?


#9

Another update on this.

Got the system working again after reinstalling everything again. Flashed spark with latest photon firmware, got it Connected with the app - got it responding with Tinker. Installed brewpi firmware on it. Reinstalled Hyperion and docker. But this time I went with the USB and not wifi. After installing Brewpi on Spark I lost Connection with it through the App. I dont know why.

So far, so good, my IPA has been yeasting on 15 to 20 degrees the last week. Maybe it will be the best beer Ive ever tasted :-).

I might try to get the wifi up and running after bottling…


#10

Good to hear! So no white screen anymore and connection between script and Spark?


#11

Hello,
I have a white screen problem too
I have installed as it goes - hypriotOS, portainer, brewpi interface, then went to console(on portainer) and installed dfu. Connected via usb and used Particle for wifi connection.
I connected to RaspPi via Putty. I tried to reinstall firmware for the 0.5.4 and also 0.5.3.rc2 and 0.5.3.rc3. It went successfully, but the screen is still white.

Any ideas what to do/try next?

Thanks

@edit2
Temperature sensors (fridge and beer) are working and it updates on Brewpi,
Screen is still white. The light is like a very light blue flashing in a slow motion.


#12

If you can successfully communicate with the device and it is reading temperature sensors, then you are running the correct firmware. The white screen must be a hardware problem then.

Can you open the case and check that the display cable is correctly inserted into the display connector?
The problem is most likely the display itself, so I could send you a new one. Or alternatively, you can send the unit back and I’ll test and install it for you.


#13

Just opened and checked. I tried several times turning on and off, and the issue is with the connection. If the screen hangs loose then it worked, but if you touched it/moved it/put the case back, it turned white again.

I will send you a PM.