BrewPi 0.4.2 - How to update

I checked, and you do have the button.
Advanced settings --> control constants --> scroll down --> There it is.

I also noticed that your stderr log is not updating. It is probably owned by root, instead of brewpi.
Please run:

sudo /home/brewpi/utils/

I suspect the update process was not completely finished due to an error.

I did notice that you have your heater and cooler installed to output 2 and 3. I hope you did not connect the SSR to nr 1. Please try looking into the green connector to see whether a red LED is on inside. If it is, the output is high.

There is also a minimum wait time between heating and cooling. The default is 30 minutes, but it can be changed in advanced settings. The settings is called ‘dead time’.

Stupid browser. Changed to IE and it came up. Some times you can’t see the forest for the trees. Did as you said and its working in test mode with to toggle. Now just waiting to see if it will kick on after the min time has pasted for the compressor. Looks like it should.
Thanks for the help!!

I switched it to heat on 1 and cool on 2. The output for heat is now 0 and cool is 29. This is after the reset. I use a freezer not a frig.

It is working correctly now. Thanks again for you fast response!

Just a reminder (@moelinger) to close the site. Everyone can change change setting on your brewpi as long as you keep the link active. A bad person could visit your link and raise the temperature to kill your beer.

Please change it, and maybe put a password on it (should be quite simple!)

I only had that open for Elco to look at. It is closed now. Thanks

No problem @moelinger ! Always be safe when opening up something to the big public…

Arduino users
This new release did not fit into an Arduino and it is unlikely we can make it fit in the future. To keep using your Arduino version of BrewPi, and to prevent our update scripts from updating the UI to something that only works with 0.4.0 and later, change your branch to the ‘legacy’ branch. Run the updater with --ask. It will ask you which branch to check out. Choose ‘legacy’.

cd ~/brewpi-tools
sudo python --ask

This solved my Arduino issues after inadvertently updating without thinking that I’m now “Legacy” and old-school with my Arduino! Thanks Elco!

White flag raises slowly!

I give up. New user here trying to setup a system using RPI b3 and a arduino uno r3 and I think I’m stuck due to the above issue. Please note I have no internet at home and can only access files via phone or a trip to work for their wifi. Brewpi starts fine after install (2nd attempt) and I get script running (oem blink) but can’t upload brewpi arduino hex. I downloaded the hex from github and loaded the arduino via xloader but still have issues. Attempted loading hex thru maintenance panel again and I receive instructions mirroring the above quoted issue.

Now, when I attempt to revert to legacy with this process I get “command not found”. What am I doing wrong? Do I need internet access to perform this process?

I’m a diesel mechanic by trade but I veer to the geeky side so please be patient. Just wanna brew some beer!


Yes, you do need Internet to do this.
It will need to download the legacy branch from GitHub.

I cannot tell you what the problem is with ‘command not found’ if you do not copy the line above that states which command it was trying to run.

Since posting my question I’ve accessed a web link and still get the same/similar response.

“cd ~/brewpi/tools” wo/quotes returns
"Bash: cd: /home/pi/brewpi-tools: No such file our directory found"

“sudo python --ask” returns
"Python: can’t open file ‘’: [Errno 2] No such file our directory"

I’m sure it something I’ve done our forgot to do. Are these command files and directories purged after install? Is there anyway to load legacy during the install process?

Again, thanks for the help.


The right directory is ~/brewpi-tools, not brewpi/tools

And if the first command fails, so will the second, because you are not in the right directory.
I recommend using putty to login to your pi so you can copy/paste commands. And use tab to auto-complete when you enter them manually.

Yea, I typed that wrong, it was command as ‘-’, not ‘/’. My bad.

I’ll try the putty route and try again.

Thanks, Dan

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Mar 26 09:56:06 2016
pi@raspberrypi:~ $ cd ~/brewpi-tools
-bash: cd: /home/pi/brewpi-tools: No such file or directory
pi@raspberrypi:~ $ cd ~/brewpi-tools
-bash: cd: /home/pi/brewpi-tools: No such file or directory
pi@raspberrypi:~ $ cd ~/brewpi-tools
-bash: cd: /home/pi/brewpi-tools: No such file or directory
pi@raspberrypi:~ $ sudo python --ask
python: can’t open file ‘’: [Errno 2] No such file or directory
pi@raspberrypi:~ $ sudo python --ask
python: can’t open file ‘’: [Errno 2] No such file or directory
pi@raspberrypi:~ $ cd ~/brewpi-tools
-bash: cd: /home/pi/brewpi-tools: No such file or directory

Same results

pi@raspberrypi:~ $ sudo ~/brewpi-tools/
sudo: /home/pi/brewpi-tools/ command not found

Forgot to include this earlier, this was the original issue when attempting to revert to legacy.


eh, dit you clone the brewpi-tools repo or did you skip that step?

At this point I’m unsure to be honest. Nice thing about these raspberry is the card memory and the ability to start from scratch. Learn more every attempt.

I’m in the process of starting over, again. I think putty will help also.

Thanks for the help, I’ll respond with results later.



Reloaded everything fresh, immediately reverted back to ‘legacy’ which worked fine other than a web repository issue which timed out and repaired itself.

Still had issues loading the arduino hex using the brewpi interface so I used xloader again. Rebooted entire system and I now have proper script running with temps waiting for sensors. Hopefully that will go well and I can get a Guiness clone going that I’ve had waiting far far too long.

Happy Dan