BrewPi 0.4.2 - How to update

I have not tested this, but I think this should still work:

Download a release manually:

Upload via the web interface.

took a couple of goes but it worked thanks mate!

I have a brewpi spark handling fridge constant mode at 40f for my True T49 fridge for bottle storage. The new version works well but it has changed a few things and I’ve seen a few oddities.

1: Previous to 0.4.x the fan would only come on when the compressor came on to adjust the temperature. Now the fan is on all the time, except when earlier today it turned it off for ~6 hours before I noticed my temp graph looked all funky. I messed with it a bit and it seems to be back to normal, maybe.

2: I used to be able to adjust the max over/under for fridge constant, ie, if I have it set to 40f I had the max over set to 1.5f it wouldn’t turn on the compressor and fan until it was 41.5f. Now I have no control, and while it is super accurate it is not as power efficient as used to be. My fridge was built in 1993 and the compressor is rated for ~9 amps, so this was an area of interest for me.

When is multi chamber coming? I’m about to get back into brewing and I want to run another fridge for a fermentation chamber. Would be nice to have one brewpi control both.

  1. I would configure the fan as manual actuator and turn it ON permanently.

  2. You can now adjust the PWM period for the fridge. To have it turn on less often, increase the PWM period. For your bottle storage 1 hour will be fine probably. Set it to 3600.

Multi chamber: this requires a whole new web interface and data storage, so it will take us a few months.

I’m having some difficulties updating. I ran, and it said there was an error updating the firmware for my photon and that it was restoring defaults. After that, the brewpi had a blank white screen. I ran the script, and got the “unable to connect to device” error message. I tried putting the photon in DFU mode and tried both steps again, but with the same errors. A

t this point, I can’t get either script to recognize the photon. I don’t think the issue is cables or power supply, as this exact hardware setup was running just fine a week ago. Any ideas? Thanks!

You will have to recover from that with
You will have to put the Photon in DFU mode first, before running the command. The LED should be blinking yellow.

Just updated to 0.4.2 through the update script. Everything updated successfully, however now the heater and cooler no longer do anything. I have everything on default. The script is running and it will say it’s cooling or heating but nothing will kick on. This was working before the update.

This sounds like the same issue that Dan had in this thread:

Resetting to default settings seemed to work. From which version did you update?
Do you see anything strange in the log file?

Can you try whether turning it on and off again helps before resetting to factory defaults?

I believe it was 0.2.10. It is not idling, says it has been cooling for 4 hours but the frig does nothing. No light on the relay.
I have rebooted. I do not have a reset to factory defaults button in advanced. Logs are below. I did try to change outputs but got nowhere…

EST 2016)
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Jan 20 2016 16:41:01 controller debug message: INFO MESSAGE 12: Received new setting: heater1PwmPeriod = 4
Jan 20 2016 16:41:09 Installed devices received: [{“a”: “2898AE730600006E”, “c”: 1, “b”: 0, “d”: 0, “f”: 6, “i”: 0, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.324}, {“a”: “28DC077406000081”, “c”: 1, “b”: 1, “d”: 0, “f”: 9, “i”: 1, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 66.875}, {“a”: “2866937306000067”, “c”: 1, “b”: 0, “d”: 0, “f”: 5, “i”: 2, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.664}, {“c”: 1, “b”: 0, “d”: 0, “f”: 2, “i”: 4, “h”: 1, “p”: 11, “t”: 4, “v”: 0.0, “x”: 0}, {“c”: 1, “b”: 0, “d”: 0, “f”: 3, “i”: 5, “h”: 1, “p”: 10, “t”: 4, “v”: 100.0, “x”: 0}]
Jan 20 2016 16:41:09 Available devices received: [{“c”: 1, “b”: 0, “d”: 0, “f”: 0, “i”: -1, “h”: 1, “p”: 16, “t”: 0, “x”: 0}]
Jan 20 2016 16:41:52 Installed devices received: [{“a”: “2898AE730600006E”, “c”: 1, “b”: 0, “d”: 0, “f”: 6, “i”: 0, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.324}, {“a”: “28DC077406000081”, “c”: 1, “b”: 1, “d”: 0, “f”: 9, “i”: 1, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 66.762}, {“a”: “2866937306000067”, “c”: 1, “b”: 0, “d”: 0, “f”: 5, “i”: 2, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.664}, {“c”: 1, “b”: 0, “d”: 0, “f”: 2, “i”: 4, “h”: 1, “p”: 11, “t”: 4, “v”: 0.0, “x”: 0}, {“c”: 1, “b”: 0, “d”: 0, “f”: 3, “i”: 5, “h”: 1, “p”: 10, “t”: 4, “v”: 100.0, “x”: 0}]
Jan 20 2016 16:41:53 Available devices received: [{“c”: 1, “b”: 0, “d”: 0, “f”: 0, “i”: -1, “h”: 1, “p”: 16, “t”: 0, “x”: 0}]

Jan 20 2016 21:11:09 {“BeerTemp”:66.76,“BeerSet”:40.00,“BeerAnn”:null,“FridgeTemp”:68.23,“FridgeSet”:22.00,“FridgeAnn”:null,“RoomTemp”:70.81,“State”:4}
Jan 20 2016 21:13:10 {“BeerTemp”:66.76,“BeerSet”:40.00,“BeerAnn”:null,“FridgeTemp”:68.23,“FridgeSet”:22.00,“FridgeAnn”:null,“RoomTemp”:70.70,“State”:4}
Jan 20 2016 21:15:11 {“BeerTemp”:66.76,“BeerSet”:40.00,“BeerAnn”:null,“FridgeTemp”:68.23,“FridgeSet”:22.00,“FridgeAnn”:null,“RoomTemp”:70.59,“State”:4}
Jan 20 2016 21:17:12 {“BeerTemp”:66.76,“BeerSet”:40.00,“BeerAnn”:null,“FridgeTemp”:68.23,“FridgeSet”:22.00,“FridgeAnn”:null,“RoomTemp”:70.59,“State”:4}
Jan 20 2016 21:19:13 {“BeerTemp”:66.76,“BeerSet”:40.00,“BeerAnn”:null,“FridgeTemp”:68.23,“FridgeSet”:22.00,“FridgeAnn”:null,“RoomTemp”:70.48,“State”:4}

Ok, thanks for your input.

During the install update, did you go through EEPROM reset and restoring devices?

You can now fix this by clicking the factory defaults button in advanced settings and re-installing your devices manually.

I did not get that option this time. I don’t have that button.
go to -removed- and see what you think.

I checked, and you do have the button.
Advanced settings --> control constants --> scroll down --> There it is.

I also noticed that your stderr log is not updating. It is probably owned by root, instead of brewpi.
Please run:

sudo /home/brewpi/utils/

I suspect the update process was not completely finished due to an error.

I did notice that you have your heater and cooler installed to output 2 and 3. I hope you did not connect the SSR to nr 1. Please try looking into the green connector to see whether a red LED is on inside. If it is, the output is high.

There is also a minimum wait time between heating and cooling. The default is 30 minutes, but it can be changed in advanced settings. The settings is called ‘dead time’.

Stupid browser. Changed to IE and it came up. Some times you can’t see the forest for the trees. Did as you said and its working in test mode with to toggle. Now just waiting to see if it will kick on after the min time has pasted for the compressor. Looks like it should.
Thanks for the help!!

I switched it to heat on 1 and cool on 2. The output for heat is now 0 and cool is 29. This is after the reset. I use a freezer not a frig.

It is working correctly now. Thanks again for you fast response!

Just a reminder (@moelinger) to close the site. Everyone can change change setting on your brewpi as long as you keep the link active. A bad person could visit your link and raise the temperature to kill your beer.

Please change it, and maybe put a password on it (should be quite simple!)

I only had that open for Elco to look at. It is closed now. Thanks

No problem @moelinger ! Always be safe when opening up something to the big public…

Arduino users
This new release did not fit into an Arduino and it is unlikely we can make it fit in the future. To keep using your Arduino version of BrewPi, and to prevent our update scripts from updating the UI to something that only works with 0.4.0 and later, change your branch to the ‘legacy’ branch. Run the updater with --ask. It will ask you which branch to check out. Choose ‘legacy’.

cd ~/brewpi-tools
sudo python --ask

This solved my Arduino issues after inadvertently updating without thinking that I’m now “Legacy” and old-school with my Arduino! Thanks Elco!