[Solved] White Screen on Spark


I am was originally having trouble with getting the devices to install and tried following the instructions here

Everything else seemed to be running correctly.

Needless to say those instruction didn’t work for me or I screwed them up somehow. The only Limux I really know is from trying to get this thing up and running. Now my Spark will only display a white screen. I’ve tried updating firmware and re-installing BrewPi. Both seemed to install correctly, but still a white screen. I tried running ls /dev/ttyA* and what * get is pi@raspberrypi ~ $ ls /dev/ttyA*
which is obviously missing the default port that is normally used.

I did at one point have the sensors connected to it and the spark was receiving data on screen. Like I said everything seemed to be working except installing the devices.

Is there a way out of this mess?

Hi Blue82,

If you only get a white screen, it sounds like your Spark Core is not running BrewPi anymore.
Our update script relies on that to be able to send the firmware over serial, so we are going to have to resort to a different way of updating: programming in DFU mode.

Please refer to this topic:

In summary: you have to put your core into DFU mode, by holding the mode button while plugging in USB. The mode button is under the pin hole closest to the Dutch flag. Then when the yellow LED is flashing inside, flashDfu.py will program the latest firmware to your Spark Core.

Thanks for the assist Elco. Everything’s up and running nicely.

I’ve also been seeing an all white screen with my BrewPi, but in my case the firmware is definitely loaded and running. The script is still communicating with it and it’s still controlling my fridge correctly.

Usually when I’ve seen it go white, I can power cycle the BrewPi and get the interface back, but it will always go back to all white again within, say, 15 minutes.

I’m on version 0.2.10, but I was getting the white screen on 0.2.7, as well. So far I haven’t seen anything in the script logs when it happens. Is there any debugging info I can collect from the spark core?

1 Like

I am not sure whether this is a hardware or software problem. I don’t think there is any debugging you can get. I can swap out the board for you for a new one, but we are also rewriting the display driver code, so it might be worth waiting until that update to see whether the problem goes away.

Okay, no problem. I’m going to hang onto it for now, since it’s still controlling my fridge normally.

As a further data point, I factory reset my spark core and reinstalled via dfu-util. Same behavior of coming up with the interface and then eventually going back to all white.

I’ll keep an eye out for the updated display driver code.



I am trying to run sudo python /home/brewpi/utils/flashDfu.py

but it gives me the following error:

/home/brewpi/utils/downloads/dfu-util: 1: /home/brewpi/utils/downloads/dfu-util: Syntax error: word unexpected (expecting “)”)

Any thoughts?

Can you give a bit more lines than that? A console copy/paste including the commands.
Are you running it on a pi?
Can you try cd’ing into the utils directory and run it from there?

I was running from Linux Mint. Running the command from a Pi worked like a charm. Spark is now up and running just fine.